CB goes Captcha!

12 years 6 months ago #31276 by houbahop
Hi everyone,

I was having the problem of the capcha image not showing when selecting one of the three language of my website (with joomfish).

The problem is solved now (thanks beat, nant). The cause was that my language file was modified. At the beginning of it, there were some extra characters (before '<?php'), that you only see with an hexadecimal editor.

I have removed them and it works

I'm not sure of how those chars have arrived here, but my guess is that if you put you cursor on the first row, do a carriage return and then, delete the new empty line created, there are some invisible characters that remains at the beginning of the file. It may be related with an editor. Usually I use notepad to modify my files.

But even with notepad, you don't see those three caracters.


Thanks to CB team for support ;-)
12 years 6 months ago #31288 by ShoestringWebs
Image still not showing up.

CB 1.0.2

GD2 library installed; installed Freetype library

Database Version: 4.1.21-standard
PHP Version: 5.0.5
Web Server: Apache/1.3.37 (Unix) mod_auth_passthrough/1.8 mod_log_bytes/1.2 mod_bwlimited/1.4 FrontPage/5.0.2.2635.SR1.2 mod_ssl/2.8.28 OpenSSL/0.9.7a PHP-CGI/0.1b
WebServer to PHP interface: cgi
Joomla! Version: Joomla! 1.0.11 Stable [ Sunbow ] 28 August 2006 20:00 UTC

Register Globals Emulation: OFF
Register Globals: OFF
Magic Quotes: ON
Safe Mode: OFF
File Uploads: ON
Session auto start: OFF
Session save path: none
Short Open Tags: ON
Output Buffering: OFF
Open basedir: none
Display Errors: ON
XML enabled: Yes
Zlib enabled: Yes
Disabled Functions: none

Session Support enabled

Session Directory / Unwriteable

No Joomfish

Update: My tech support has tested imagettftext() and is satisfied that it is working properly.

Post edited by: ShoestringWebs, at: 2007/02/16 19:14
12 years 6 months ago #31289 by Kirck
Hello, I can see the image code but i tested it and i see this alert "Invalid Security Code".

I use the jsmf login module (joomlahacks).
12 years 6 months ago #31298 by alibak
Hi, as i mentioned on a previous post... ( www.fineart.es ) that captcha works in jomcomment! so my server is fine! GD2 installed... but image for cb captcha is NOT showing up!

here's my system info:

Joomla! Register Globals Emulation: ON
Register Globals: ON
Magic Quotes: ON
Safe Mode: OFF
File Uploads: ON
Session auto start: OFF
Session save path: /tmp
Short Open Tags: ON
Output Buffering: OFF
Open basedir: none
Display Errors: ON
XML enabled: Yes
Zlib enabled: Yes
Disabled Functions: none

thanks.
Ali
12 years 6 months ago #31299 by alibak
alibak wrote:

Hi, as i mentioned on a previous post... ( www.fineart.es ) that captcha works in jomcomment! so my server is fine! GD2 installed... but image for cb captcha is NOT showing up!

here's my system info:

Joomla! Register Globals Emulation: ON
Register Globals: ON
Magic Quotes: ON
Safe Mode: OFF
File Uploads: ON
Session auto start: OFF
Session save path: /tmp
Short Open Tags: ON
Output Buffering: OFF
Open basedir: none
Display Errors: ON
XML enabled: Yes
Zlib enabled: Yes
Disabled Functions: none

thanks.
Ali



again, i'm using joomla stable 1.012 and cb stable 1.02

and this is the rest of info:
PHP built On: Linux server038.serverquality.com 2.6.9-42.0.3.ELsmp #1 SMP Fri Oct 6 06:21:39 CDT 2006 i686
Database Version: 4.1.21-standard
PHP Version: 4.4.2
Web Server: Apache/1.3.37 (Unix) mod_auth_passthrough/1.8 mod_log_bytes/1.2 mod_bwlimited/1.4 PHP/4.4.2 FrontPage/5.0.2.2635.SR1.2 mod_ssl/2.8.28 OpenSSL/0.9.7a
WebServer to PHP interface: apache
Joomla! Version: Joomla! 1.0.12 Stable [ Sunfire ] 25 December 2006 01:00 UTC
User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.9) Gecko/20061206 Firefox/1.5.0.9
12 years 6 months ago #31317 by beat
To SUMMARIZE problems and solutions:

- if you don't see the captcha image appearing:
  1. Check that the FreeType library is installed for GD2
  2. Check that you don't have a php file which should be silent, e.g. cb language file, outputing characters. Typically empty lines or invisible chars (characters invisible in Wordpad and other editors) before the "<?php" at the begining or after the "?>" at the end of the file.
We are not aware of other problems regarding image not appearing.

- if you see the captcha, but a correct number is not recognized, it's a php session problem:
  1. Check if php sessions are enabled and if autostart is set to off.
  2. Check if the tmp directory is writable.
  3. Check if your site template (try the default one) or another extension doesn't reinitialize the php sessions.
  4. PM access to Nick to investigate if problem subsists.
There is still one site not working with correct replies of code, but doesn't accept the reply, that we need to find out why.

Beat - Community Builder Team Member

Before posting on forums: Read FAQ thoroughly -- Help us spend more time coding by helping others in this forum, many thanks :)
CB links: Our membership - CBSubs - Templates - Hosting - Forge - Send me a Private Message (PM) only for private/confidential info
Moderators: beatnantkrileon
Time to create page: 0.409 seconds