CB goes Captcha!

13 years 4 months ago #32131 by marcus178
Replied by marcus178 on topic Re:CB goes Captcha!
nant wrote:

parth wrote:

1. no freetype library installed (check with your host provider)
2. Bad chars in language file (UTF-8 BOM chars)
3. Bad (extra) chars in site template file (you can verify this by testing out the joomla template on your site).


Thanks Nant for your Quick reply.

Can you clarify in simplified language points 2 & 3 ? Maybe with some examples


first of all - have you verified that you have freetype support?

if yes, then please let us know what language file-plugin you are using.

if you are using a language plugin then perhaps you have a UTF-8 encoded language file in which case perhaps your file has BOM chars in the begining - google BOM to see what this is.

if the language file is ok or if you are using the default english file then perhaps your template is introducing some html code that interferes with captcha image generation. To verify this - if you are using your own template - you can activate the joomla preinstalled template.


Ok so if you have determined that there is a problem with the template, what needs to be done to correct it.

Please Log in to join the conversation.

13 years 4 months ago #32134 by Soroc
Replied by Soroc on topic Re:CB goes Captcha!
Narya wrote:

I can confirm:
It works like a charm.
My settings are:
GD 2.0
CB 1.0.2
Joomla 1.0.12

Great work. And fast as well :)

Thanks.


Same here, and I am extremely pleased with how well it works...now that I finally remembered to rename the original Login and Registration PHP files. Bots just call those out by name, so at first I was still getting spambots registering. (doh!)

Now however, I have gone from several spambot registrations per day to *none* in over two weeks! Woot! You guys own!

Please Log in to join the conversation.

13 years 4 months ago #32161 by parth
Replied by parth on topic Re:CB goes Captcha!
1. Free type Support: Yes this is verified.

Here's info from the Joomla System Info ( phpinfo)

gd
GD Support enabled
GD Version bundled (2.0.28 compatible)
FreeType Support enabled
FreeType Linkage with freetype
FreeType Version 2.1.9
GIF Read Support enabled
GIF Create Support enabled
JPG Support enabled
PNG Support enabled
WBMP Support enabled
XPM Support enabled
XBM Support enabled

gettext

GetText Support enabled


2. Bad chars in language file (UTF-8 BOM chars)

I am using english.php ( for Joomla) & default english language plugin for CB. Have checked both files for spaces before & after php start & end tags.

Have Checked the language files but still attaching here for your reff.

3. Bad (extra) chars in site template file (you can verify this by testing out the joomla template on your site).

Have tried with default Joomla templates to no avail.

One thing i noticed with some of the ppl having the same problems,

the url of the image
opensourcepoint.com/cioforum/index2.php?option=com_comprofiler&task=tabclass&Itemid=1&tab=getcaptchatab&no_html=1

this url shows the image for some of the users here ( i tried the URLS ) But in my case you'll see that image is not showing at that URL.

Attachment langfiles.zip not found



Post edited by: parth, at: 2007/02/28 04:01

Php-Nuke to Mambo to Joomla...
My Evolution goes on!
Need Joomla Development?
Drop us mail! www.tekdi.net - sales@tekdi.net
Our CB extensions :
CB Adsense , CB User RSS, CB-Eventlist My Events & CB-Eventlist Attended Events, CB Network Suggest
Joomla Extensions, Training & Support
techjoomla.com/
Check Out our Joomla extensions at extensions.joomla.org/extensions/owner/tekdi/1
extensions.joomla.org/extensions/owner/techjoomla/1
Attachments:

Please Log in to join the conversation.

13 years 4 months ago #32164 by 2adventure
Replied by 2adventure on topic Re:CB goes Captcha!
I was hoping some more info from you Nant, I am little kind of disappointed :(

I am still in trouble. My host provider does not give any tech support at all.

I checked and I do not have the libraries and neither the Image Magic that is probably supposed to be installed before libraries.

The worse is that I do not have root access, but I am sure there most be a way to install this libraries and Image Magic through ftp or Joomla installations manager????? Am I wrong?

I trust you know a way to do it….!!!!!!!;)

Please Log in to join the conversation.

13 years 4 months ago #32172 by nant
Replied by nant on topic Re:CB goes Captcha!
2adventure wrote:

I was hoping some more info from you Nant, I am little kind of disappointed :(

I am still in trouble. My host provider does not give any tech support at all.

I checked and I do not have the libraries and neither the Image Magic that is probably supposed to be installed before libraries.

The worse is that I do not have root access, but I am sure there most be a way to install this libraries and Image Magic through ftp or Joomla installations manager????? Am I wrong?

I trust you know a way to do it….!!!!!!!;)


Your host provider must support you on this. There is no way to install libraries on your own. The captcha plugin does not need imagmagick - it needs GD libraries with freetype font support.

Please Log in to join the conversation.

13 years 4 months ago #32173 by nant
Replied by nant on topic Re:CB goes Captcha!
parth wrote:

1. Free type Support: Yes this is verified.

Here's info from the Joomla System Info ( phpinfo)

gd
GD Support enabled
GD Version bundled (2.0.28 compatible)
FreeType Support enabled
FreeType Linkage with freetype
FreeType Version 2.1.9
GIF Read Support enabled
GIF Create Support enabled
JPG Support enabled
PNG Support enabled
WBMP Support enabled
XPM Support enabled
XBM Support enabled

gettext

GetText Support enabled


2. Bad chars in language file (UTF-8 BOM chars)

I am using english.php ( for Joomla) & default english language plugin for CB. Have checked both files for spaces before & after php start & end tags.

Have Checked the language files but still attaching here for your reff.

3. Bad (extra) chars in site template file (you can verify this by testing out the joomla template on your site).

Have tried with default Joomla templates to no avail.

One thing i noticed with some of the ppl having the same problems,

the url of the image
opensourcepoint.com/cioforum/index2.php?option=com_comprofiler&task=tabclass&Itemid=1&tab=getcaptchatab&no_html=1

this url shows the image for some of the users here ( i tried the URLS ) But in my case you'll see that image is not showing at that URL.

Attachment langfiles.zip not found



Post edited by: parth, at: 2007/02/28 04:01


please PM me a URL and backend access and I will take a look (when I get some time) - perhaps you have encountered another system that is blocking the image generation.

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.490 seconds