CB_Login causes Javascript error in IE

10 years 2 months ago #91980 by jeffhoneyager
After hours and hours I finally found cb_login is causing javascript errors in IE (all other real browsers are okay).

The error is: 'partscollect.0.style' is null or not an object

If I unpublish cb_login - IE like it - users do not.

Any idea on how to fix this?

Joomla 1.0.15
CB 1.2
php 5.2.6
cb_login 1.2

Thank you.

Peace & Joy,
Jeff Honeyager
10 years 2 months ago #91984 by jeffhoneyager
SOLVED

The problem was in the module parameters I had "CB plugins integration" set to yes. When I set it to no, the IE error went away.

Note: I wasn't sure what it was used for. When I put the pointer over the field name for a tool-tip, the text cut off on my browser. So I couldn't read the full tip.

Hope this helps someone with the same problem.

Peace & Joy,
Jeff Honeyager
10 years 2 months ago #92009 by beat
Thanks for sharing the solution to your issue. B)

CB integrations setting in CB Login module allows CB plugins to add content into the login module.

Only core team CB captcha and CB profileBook use that feature, and doesn't add any javascript to the mix.

So it must be due to another third-party CB plugin.

It would be interesting to know which 3pd CB plugin does that, so the devloper can be informed. To do that unpublish one by one the 3pd CB plugins and check with which the JS error goes away.

what IE version was it ?

what JS error did you get ?

Beat - Community Builder Team Member

Before posting on forums: Read FAQ thoroughly -- Help us spend more time coding by helping others in this forum, many thanks :)
CB links: Our membership - CBSubs - Templates - Hosting - Forge - Send me a Private Message (PM) only for private/confidential info
10 years 2 months ago #92019 by jeffhoneyager
When I click on IE's error/warning at the bottom left of the browser window, the error details are:

Line: 139
Char: 1
Error: 'partscollect.0.style' is null or not an object
Code: 0
URL: purposeforchrist.com

Of course the URL would be different depending upon the install.

I hope this helps. I spent hours trying to figure this one out. Only when I went to installing modules/components and plugins one by one, then testing each did the error come up.

Peace & Joy,
Jeff Honeyager
Attachments:
8 years 7 months ago #144639 by krileon
Reviewed source of fresh Joomla and CB installation with plugins integrations enabled as well as CB Captcha, CB Facebook Connect, CB Twitter, and CB ProfileBook and the JS in question is non-existant. More then likely this is JS added by your template or some other 3rd party extension that is conflicting.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
Moderators: beatnantkrileon
Time to create page: 0.410 seconds
Facebook Twitter Google LinkedIn