Public users being able to see userprofiles

13 years 11 months ago #2130 by hgr
Ok this is something I do not understand.

I have created a user list, with the user.
When a public user clicks on a user in the list, the profile is displayed.

But only the profile image and the basic information like :

Hits 2
Online Status OFFLINE
Member since 12/10/2005 02:56:39
Last Online 12/13/2005 21:28:40
Last update never

no Real information is displayed like the tabpages with contact information etc.

I have set the access to user profile in the configuration to "Everybody"

Do you really have to be loged in as a user to see the other users profile, and send them emails.

This is important, since I want to use the Community Builder list and profile instead of the standard joomla contact component.

What can I do ?
13 years 11 months ago #2148 by trail
Could you check these 3 things:

1) Are the tabs containing those questions published ?
2) Are those questions fields set to be shown on profile ?
3) Did the user you are looking at actually answer the questions ?

~Trail.

DJ Trail.
CB Co-Founder & Test-Lead.
Plugins: My Age , Starsign Matchmaking Horoscope , My Visitor , My Highscores , My ProfileID ,
My Components: Import & Invite Karma Casino (Use Test / Test)
My Modules: Many :)
13 years 11 months ago #2166 by hgr
1. Yes the fields are displayed on the contact tab and it is published

2. All fileds are published

3. Yes because I have created it in the backend.

When I checked it now I got an SQL error (see attached image) and when I tried again, the information was suddenly there ?

And I am still missing a way for public users to send emails to the user, like it is possible in the standard contact component.
13 years 11 months ago #2167 by hgr
Sorry but the blody image is to big, I am trying to attach it as a file to this post.
13 years 11 months ago #2168 by hgr
Blody Hell.

Now it should be attached ZIPed .

What a stupid forum, allows you to post but skips your files. :angry:

Attachment CBErrorImage.zip not found

Attachments:
13 years 11 months ago #2175 by JoomlaJoe
Looks like you are using some sort of customization to track page views? Problem is that there is a bad primary key set up between the viewer_id, profile_id, and lastip. I'd talk with the author about cleaning that up. Actually the primary key maybe fine...it may have needed to be an update on the count column instead of an update...not really sure since I'm not the author :silly:

Post edited by: joomlajoe, at: 2005/12/15 17:42

JoomlaJoe *The developer formally known as MamboJoe*
CB Core Team
Moderators: beatnantkrileon
Time to create page: 0.428 seconds
Facebook Twitter Google LinkedIn