Problems installing CB Subs

8 years 5 months ago #184695 by joshuadwatt
I have read the instructions and followed them and I am unable to get CBSubs to install correctly. I am getting a error stating,"The required free ionCube loader for your server type and php version is not installed. Please contact your hoster to install it for you, or visit ionCube free downloads page of ionCube loaders for the loader and instructions. In case of problems insalling the loader, please contact ionCube support directly after checking their support forum. Thanks."

I have 1 and 1 as my hosting server and they provided me this document.

faq.1and1.com/scripting_languages_supported/php/16.html

I have installed it using their method, ioncube installation windows package, and loader-wizard.php. It gives me successful ioncube loader installations (as seen with the attached screen shots)



When I install the cbplug_CBSubs_MAIN_122-E.zip file through the CB Plugin Manager I still get the error.

I am placing the php.ini file in the ioncube directory folder. I also read somewhere that the file needs to be a php5.ini file so I tried that also and it didn't work. I am out of ideas to try. I've have even read the manual and it still isn't working. ;)

Any help/suggestions would be great!
Attachments:
8 years 5 months ago #184754 by joshuadwatt
Ioncube support responded back to me saying, "Please note that if encoded files in a different directory fail then you should attempt to copy the php.ini file to each directory in which you have encoded files."

Which directory/folder do the ioncube php.ini files need to be placed to get this working?
8 years 5 months ago #184789 by nant
I have typically seen this (on some hosts) needed in both site root folder and administrator folder
The following user(s) said Thank You: joshuadwatt
8 years 5 months ago #184880 by joshuadwatt
Thanks, I tried that then the it wouldn't upload the cbplug_CBSubs_MAIN_122-E.zip

One thing I noticed is that my Maximum upload size went from 40M to 2M after moving the php.ini file to the admin directory.

This is the lingo to the right of the Upload & Install button before and after the move:

Before: Maximum upload size: 40M (upload_max_filesize setting in file /usr/lib/php5/php.ini )
After: Maximum upload size: 2M (upload_max_filesize setting in file /homepages/23/d374514447/htdocs/test/administrator/php.ini )

Is there a way that I can have it in the admin directory and have the 40M file upload size?
8 years 5 months ago #184889 by nant
yeah - you need to make sure that the correct max upload filesize parameter is also set in your php.ini file (see our tutorials for sample).
8 years 5 months ago #185000 by joshuadwatt
Problem solved!

For 1 & 1 hosting you need to add the php.ini file to the root directory and the administrator directory. In order to fix you the small max upload size you need to add the following command to the php.ini file.

upload_max_filesize = 40M

Thanks for your help!
Moderators: beatnantkrileon
Time to create page: 0.444 seconds

Facebook Twitter LinkedIn