[FIXED]authorize.net auto-recuring: 1st payment 2x

10 years 5 months ago #98636 by beat
lindseycreative wrote:

Hi Beat,

Sorry for the delay. Sent them off. Thanks!

John


No worries.

Got the mail, thanks. Have replied: logs to check and understand issue are missing from the mail... ;)

We will take it further by mail ;)

...and report back when issue is found/understood and resolved.


Actually the workaround you explained above does solve your problem as i now understood ?


Tagging as potential bug for investigation
#1028

Beat - Community Builder Team Member

Before posting on forums: Read FAQ thoroughly -- Help us spend more time coding by helping others in this forum, many thanks :)
CB links: Our membership - CBSubs - Templates - Hosting - Forge - Send me a Private Message (PM) only for private/confidential info
10 years 2 months ago #108536 by jbourque
Has there been any solution to this problem? I have a client that only wants recurring billing and is being billed twice.

He swears that the other option does not activate the recurring billing

Thanks
Joe
10 years 2 months ago #108544 by beat
The initial problem was fixed in currently available CBSubs 1.0.2.

I'm not aware of other problems.

Could you please describe your client's more in details please ?

In "History" you will find all details of actions and evengts to make sure it's not a user error.

Otherwise access to the admin area would help to understand the issue too, in which case you can, if you wish, and with customer's authorization, PM me the access (bottom left icon of this post).

Beat - Community Builder Team Member

Before posting on forums: Read FAQ thoroughly -- Help us spend more time coding by helping others in this forum, many thanks :)
CB links: Our membership - CBSubs - Templates - Hosting - Forge - Send me a Private Message (PM) only for private/confidential info
10 years 2 months ago #108546 by jbourque
I would be happy to give you access to the site to take a look. He got the following email from Authorize.net this morning.

The ARB subscription was submitted on the 17th and the transaction for this subscription posted on the 18th. A transaction also posted on the 17th that is not set up with the subscription, but was processed as a regular transaction the same time your subscription was submitted. You will need to check with your developer to ensure that a single transaction is not submitted at the time the subscription is set up to verify the card, because the regular ARB transaction will process the next day, but only for the first payment. Every payment after that will post automatically on the start date of each month.

contact your developer to review the script to make sure that there is no immediate charge when the subscription is sent to the gateway.


I will create you an account.

Joe
10 years 2 months ago #108547 by jbourque
I have created you an account pls let me know how you want me to get it to you.

Joe Bourque
Above Web Media
www.AboveWebMedia.com
10 years 2 months ago #108550 by jbourque
Beat I sent you a PM with the account info

Joe
Moderators: beatnantkrileon
Time to create page: 0.498 seconds
Facebook Twitter Google LinkedIn