CBSubs 1.0.3 Released!

9 years 9 months ago #111389 by beat
This thread discusses the Content article: CBSubs 1.0.3 Released!

Many thanks to all who helped making CBSubs extremely Stable with release 1.0.3.

Our TOP priority remains the gateways API and a few more gateways, and should now be part of our next features release CBSubs 1.1.


Here is the changelog for maintenance release CBSubs 1.0.3:

28 bugs, mostly minor, fixed, and 7 minor features implemented, mostly for better expected behavior:

Bug #1167: Paypal free trial on auto recurring payment subscription not functioning
Bug #1175: Multiple language translations for e-mails not functioning
Bug #1182: Paypal: cancellations of reversal don't revert reversed basket and subscriptions
Bug #1184: Mandatory/recurring set wrongly in backend user edit depending on way things are saved on blocked users
Bug #1187: Redirects on login for plan under workflows not functioning
Bug #1188: VM missing installation check and backend new user trigger
Bug #1189: j1.5: Section and Category blog views do still display "Read more" (with cbsubs link) in addition of "Subscription needed"
Bug #1220: CBSubs Fields integration plugin only first 5 fields work of 10
Bug #1227: Check that a subscription does not have any child subscriptions before deleting it
Bug #1236: Authorize.net AIM+ARB seems again double-billing
Bug #1237: Error message "Chosen plans combination is not allowed" very unclear
Bug #1238: A subscription can be upgraded only to 1 new plan, never again to another
Bug #1240: Backend: notice displayed on a notification display detail if user got deleted
Bug #1245: Paypal IPN fails validation if last character of item name is a space
Bug #1247: Paypal unsubscribe link not working with paypal encryption ON
Bug #1251: Backend: Link missing in merchandises at top of edit plan
Bug #1261: Language typo "to small/large" should be "too small/large"
Bug #1262: Check that a plan does not have any child plans before deleting it
Bug #1263: Figure 91 simulation from CB documentation
Bug #1264: When does tab/field protect message fire
Bug #1268: Content integration plugin: access control by URL : minor notice with arrays in GET
Bug #1269: Partially-Refunded is cancelling subscriptions, but should not cancel, and should be recorded correctly in payments
Bug #1270: Status and payment types in messages not translated
Bug #1272: SQL Actions integration not firing from user management
Bug #1275: Direct redirect to off-line payment broken (displays "Payment basket does not login"«»)
Bug #1276: Authorize.net : error was displayed "unkown" instead of com.error when HTTPS POSTs were not supported
Bug #1277: Backend: When clicking too fast on main page, small JS error: Error: respField is not defined
Bug #1281: Backend: Plans filters do not function for subscriptions, merchandises and donations views

Feature #1162: Content integration global plugin settings default value for display introduction was Yes, causing confusion while working fine
Feature #1163: Content integration plugin: Settings texts description changes
Feature #1176: Hiding a field on registration that is required causes validation error
Feature #1253: New Integration plugin for http/https requests with substitutions
Feature #1260: Folderaccess : add warnings for protecting root folder and also howto uninstall texts
Feature #1271: For payments and baskets, distinguish states "Refunded" vs "Reversed"
Feature #1280: Backend: Baskets view: Pay was possible only for Pending: not for NotInitiated on Offline payments



EDIT: added changelog

Post edited by: beat, at: 2009/09/16 22:51

Beat - Community Builder Team Member

Before posting on forums: Read FAQ thoroughly -- Help us spend more time coding by helping others in this forum, many thanks :)
CB links: Our membership - CBSubs - Templates - Hosting - Forge - Send me a Private Message (PM) only for private/confidential info
9 years 8 months ago #111546 by mcooper03
Beat,

I skipped version v1.0.2 and I'm still running v1.0.1. Is it OK to go straight to v1.0.3 or do I need to upgrade to v1.0.2 first?
9 years 8 months ago #111550 by nant
mcooper03 wrote:

Beat,

I skipped version v1.0.2 and I'm still running v1.0.1. Is it OK to go straight to v1.0.3 or do I need to upgrade to v1.0.2 first?


You can go directly to 1.0.3, just follow the upgrade instructions in the new documentation.
9 years 8 months ago #111658 by klempit
Thank you for making the URL plugin happen so quickly. The responsiveness of the CB team to our suggestion was great to see. While it fits our business model perfectly, I can see (and hope) that it helps a lot of other CBSubs users make the most of this great plugin. Thanks again!
9 years 8 months ago #111661 by ndee
Hi guys,

thanks for the update!

Is there any progress on the backend language strings for translation? (don't make it too hard for people to make cbsubs more accessible for foreign languages) B)

greets,
ndee

###################
SPEED UP HELP, read first: Help us help you
###################
9 years 8 months ago #111789 by amazeika
Hello guys,

Excellent !!!, Bravo for that GET/POST HTTP request plugin. I had no idea you were working on such puglin, pleasant surprise, solved many php integration holes on my site with it :silly: .

Thanks !!!

Arunas

Post edited by: amazeika, at: 2009/09/21 13:30

Arunas Mazeika
WeXtend.com - Professional development for Joomla!.
Moderators: beatnantkrileon
Time to create page: 0.408 seconds