Security warning message w/ Authorize.net

9 years 7 months ago #115493 by tlawson84005
I am using the latest version of CBSubs. Many of my clients are getting the following warning message when they click on the credit card icon to pay for the subscription to my site (going through Authorize.net).

"Do you want to view only the web page content that was delivered securely? This web page contains content that will not be delivered using a secured HTTPS connection which could compromise the security of the entire web page."

If they select "Yes", which is the default, the page doesn't download correctly and it won't process their card. If they select "No", it works fine.

This is creating all kinds of grief for me because no one wants to see security warning messages when it comes to entering their credit card information. In addition, most people don't understand the message and click on "Yes", which or course blocks some of the page.

I need to fix this ASAP. Can anyone give me some guidance. I saw a similar post for PayPal but I don't get this warning dialog when people select PayPal. They see this when they select Authorize.net.

HELP!!!
9 years 7 months ago #115500 by krileon
You need to use HTTPS with SSL support on your host and a valid certification, which will require a dedicated IP. So you'll have to purchase a dedicated IP from your host. Then purchase a valid certificate from one of the various providers (google for your choice). I believe this information should've been outlined and provided by Authorize.net when obtaining your merchant account.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
9 years 7 months ago #115515 by tlawson84005
It is on a static IP and I did purchase the certificate. It didn't work at all until I did that.

This warning message doesn't happen on every computer but on most. The solution is working as long as they click on "NO". The only way I can figure out is to actually cancel the subscription and sign up again. That's not a viable option. What else can we do?
9 years 7 months ago #115535 by krileon
Are you using any custom buttons or content on the credit card page? This will cause a mixed content error as well. Have you also set it to submit as HTTPS in CBSubs Settings -> Credit Card?


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
9 years 7 months ago #115545 by tlawson84005
I haven't added anything to the page.
9 years 7 months ago #115574 by krileon
tlawson84005 wrote:

I haven't added anything to the page.


Please PM backend access and will investigate your installation.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
Moderators: beatnantkrileon
Time to create page: 0.388 seconds
Facebook Twitter Google LinkedIn