getting Dutch frontend translation to work

7 years 9 months ago #172321 by martysodfoot
Hi guys,

I've just finished translating the cbsubs language file for front-end use to Dutch (=dutch.php, the admin_dutch.php file is too big of a job at this point). I compiled the plugin according to instructions in the manual (page 425). I installed it as a normal plugin as suggested. I'm running cbsubs version 1.2.0 still.

I also installed the Dutch plugin for CB (version 1.2 on a 1.4 install however).

Alas, front-end still mostly in English...

Then I replaced all files in the default_language folder with Dutch versions of these files. So now I have three folders in the language section:
-cbpaidsubscriptionsdutch
-default_language
-dutch
All three of them are in Dutch for the front-end (except the before mentioned back-end admin files, which is fine)

Still for the most part the front-end remains in English. Am I missing something here? Do I need to deinstall the default_language plugin to make it work? Is there a language setting that I've missed somewhere?

Any help appreciated!

Marty
7 years 9 months ago #172350 by nant
you should not touch the default language at all.

If you post your plugin perhaps we can see what is wrong.
7 years 9 months ago - 7 years 9 months ago #172566 by bastiaan
Marty, good to hear you made the translation, I have also started with the front end, let me know if you are going to share it, so I can stop.

In general you should make sure your site is working fin in English and like Nant says, not mess with language files.

You just make another Dutch installer file, zipped with the right XML file in it.
I have already done all that so if you want help, I can make it for you or send you the set.
Just send me an email offlist.

Bastiaan

bastiaan (at) zebrafilm (dot) com
7 years 9 months ago #172637 by martysodfoot
Ok, I've reverted the changes made to the original default language files so I have the original setup of CB1.4 with the Dutch translation pack (for CB1.2) installed and CBsubs (1.2.0) with the attached Dutch language plugin installed... still no luck.

My Joomla 1.5.22 config is set to Dutch as a default in both frontend and admin.

Ideas more than welcome!


@Bastiaan: ik snap niet helemaal wat je bedoelt maar mail je wel even, thanks!
Attachments:
7 years 9 months ago - 7 years 9 months ago #172645 by bastiaan
Marty, your zip file is fine and works also.

Not sure what is not working for you so let me tell you the steps to take:
Login the backend -> community builder -> plugins

Click install plugin and select the file you posted here. Click upload and you should see a message that says success.

If there is an error message, please post it here.
You can also double check the file location:

root/components/com_profiler/plugin/language/

there should be a new "cbpaidsubscriptiondutch" folder.
Before install, make sure you take it out to be sure.

To recap:

You need to install it as a plugin, instead of manually changing files.
What you did was right but just not the right way. :-)
7 years 9 months ago #172657 by martysodfoot
Well, that's exactly what I did with the cbsubs translation: install it as a plugin. No errors on installation; all looks fine, folder is there, nothing weird.

The only files I manually changed were cb default language files (in the components/com_composer/plugin/language/default_language folder) and those I reverted back to the original English ones.

So, to recap:
- I installed the Dutch language pack for CB 1.2
- I installed the CBsubs plugin I translated

Still, all I get is English!!??

Very strange...
Moderators: beatnantkrileon
Time to create page: 0.402 seconds
Facebook Twitter Google LinkedIn