PayPal - Bug when unsubscribing

9 years 10 months ago #109146 by cavyspirit
I'm not really sure what you are saying. I followed the directions to the letter when I created my SSL documents. What exact setting in Paypal am I supposed to change?
9 years 10 months ago #109175 by Talal
I'm using encrypted forms too and since payments works just fine, I'm not sure what settings are wrong...
9 years 10 months ago #109177 by beat
It looks very much as a bug at Paypal side, likely something changed there since we implemented and tested this unsubscription feature.

Tagging for investigation and fix or workaround for next CBSubs release.
#1247

Beat - Community Builder Team Member

Before posting on forums: Read FAQ thoroughly -- Help us spend more time coding by helping others in this forum, many thanks :)
CB links: Our membership - CBSubs - Templates - Hosting - Forge - Send me a Private Message (PM) only for private/confidential info
9 years 10 months ago #109502 by cavyspirit
What do I have to do to HIDE that button for now?

Thanks,
Teresa
9 years 10 months ago #109506 by beat
cavyspirit wrote:

What do I have to do to HIDE that button for now?

Thanks,
Teresa


General Settings -> Display -> Unsubscribe -> Show unsubscribe button -> NO

Or change the "unsubscription intro text" below that YES to something like:

"To unsubscribe, please do it directly from your Paypal account: login, then go to your profile, payment subscriptions, and cancel your payment subscription from there. This will stop future payments, but your subscription here will remain valid until the next payment term and will then expire, unless you renew it here."

Beat - Community Builder Team Member

Before posting on forums: Read FAQ thoroughly -- Help us spend more time coding by helping others in this forum, many thanks :)
CB links: Our membership - CBSubs - Templates - Hosting - Forge - Send me a Private Message (PM) only for private/confidential info
9 years 10 months ago #109801 by cavyspirit
Thanks very much.

I ended up adding the text, then I ended up turning the whole thing off again.

Here's the problem that I hope get updated in the next version:

If I set the overall config to show the unsubscribe button (with or without the text), the unsub button is shown on plans that were never subscribed to in the first place. (They weren't that kind of plan.)

It seems to me that that "show unsub" button and text should be plan-based, not overall config-based.

But then again, could be operator error on my part (nothing new).
Moderators: beatnantkrileon
Time to create page: 0.428 seconds
Facebook Twitter Google LinkedIn