PayPal - Bug when unsubscribing

9 years 10 months ago #108771 by cavyspirit
The merchant ID is the main email address, right?

I didn't provide the receiver email because the email I am using is the same. It read like you should not enter it if it's the same.

Also, I had selected, use country of paypal account, which is the US. Does that need to be specifically selected?

So, if I have to add that second email and change the country to the US specifically, I have to redo the SSL documents?

I have studied that document multiple times trying to do this the right way! ;)


The manual for the receiver field says:

This text field parameter may be optionally populated (as an extra security precaution) with your PayPal Business account primary email address. If the PayPal Business parameter (see previous parameter) was set to the primary business account email address, then this setting will be the same.

For the country field it says:

This drop-down field parameter is initially configured to follow the default setting of your PayPal account. You can over-ride it if you want but in most cases it will most likely be set to the default value.

So again, honestly, I'm not really sure what you are saying that I did wrong on my configuration.
9 years 10 months ago #108773 by cavyspirit
Also, what I don't understand is, the payment gateway is working fine on regular payments AND subscription payments. So, I what I don't understand is what is different -- or what is being called differently -- in the UNSUBSCRIBE function that is causing the problem. There must be something in that process that should provide a pretty strong clue as to what specifically is broken in either my configuration or the SSL document. I'm not sure how it could be anything to do with the paypal configuration itself, since the other processes work fine. But if it is, again, it seems like it should be something to do with unsubscribing only.

Post edited by: cavyspirit, at: 2009/08/21 02:17
9 years 10 months ago #108778 by krileon
Please follow the exact instructions as I've given regardless of optional or not. This is a working configuration I am using on my live site in my signature, tested on multiple purchases. So I know the setup is working. Please try doing so and report back if resolved.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
9 years 10 months ago #108791 by cavyspirit
Still no joy. Did the configuration change and the unsub process is still throwing the exact same error.
9 years 10 months ago #108818 by krileon
cavyspirit wrote:

Still no joy. Did the configuration change and the unsub process is still throwing the exact same error.


Please PM me Joomla backend access and host access (cpanel). I will review your setup and all error logs to see if there is a conflict or configuration issue.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
9 years 10 months ago #109070 by krileon
It appears you are using paypal encryption to encrypt the form. This may not be setup properly, please disable and see if issue is still present.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
Moderators: beatnantkrileon
Time to create page: 0.397 seconds
Facebook Twitter Google LinkedIn