Joomla 2 CiviCRM User - match not found?

4 years 1 month ago #247263 by blocka2006
After installing and configuring the plugin, I created a civiCRM contact who does not have a corresponding Joomla account.

I then use the core frontend Joomla Create User account interface to create a new account (using the contact's email address).

When I click to submit the frontend form, I get the message:
CiviCRM contact not found but matching exists

I click on the confirmation email to activate the account.
I log in, and then I click a menu item to allow the user to Edit their civiCRM contact profile -- and I do not see their profile data (contact name, address, etc)

I then check in civiCRM, and a new contact has been created (instead of the matching).

I'm using Joomla 2.5.24 and civiCRM 4.4.5

Here's a movie showing the testing sequence: Screen Movie Walkthrough
4 years 1 month ago #247496 by nant
Hi and thanks for posting - I will be looking into this over the weekend and reply back here.
4 years 1 month ago #247497 by nant
Ok, I just watched the video (thanks for taking the time to record this).

Actually the fact the the plugin did not populate the email location drop-down could be the cause of the problem as without this the plugin cannot really match the the Joomla email address.

Thinking that the civicrm api has changed - will try and confirm this over the weekend and hopefully release a new fixed version.
Moderators: beatnantkrileon
Time to create page: 0.379 seconds
Facebook Twitter Google LinkedIn