UTF-8 problem?

6 years 3 months ago #243977 by jpsanudo
UTF-8 problem? was created by jpsanudo
I save the CSV using the CBJUICE 2.0 and I see that when it finds an accent or the Ñ, the value of the filed disappears. For example, the CSV that the CBJUICE creates appears with "Espa" instead of "España".

So, when I want to import my CSV, I have a problem. It doesn't show on the CB users those values. What can I do?

I am trying now to import España as EspA+a, but I don't want to do this with each accent.

Please Log in to join the conversation.

6 years 3 months ago #243978 by jciconsult
Replied by jciconsult on topic UTF-8 problem?
You have to read the file with a UTF-9 capable program if you are working on it outside of joomla. CBJUICE exports in UTF-8 and expects UTF-8 input in most circumstances. Read the documentation. If you need to manipulate the file, use an editor that reads and writes utf-8 or use Libre Office and make sure that you write in UTF-8 by setting the filter parameters correctly.

Please Log in to join the conversation.

6 years 3 months ago #243980 by jpsanudo
Replied by jpsanudo on topic UTF-8 problem?
UTF-9...hmmm I was trying with NotePad++, and saving again and again in UTF-8, I'll try to find a reader for UTF-9, and I'll tell you.

Please Log in to join the conversation.

6 years 3 months ago #243984 by jciconsult
Replied by jciconsult on topic UTF-8 problem?
Use libre office, it should do it. I expect that. I would try to work in UTF-8

Please Log in to join the conversation.

6 years 3 months ago #243985 by jpsanudo
Replied by jpsanudo on topic UTF-8 problem?
Yes, I has working with UTF-8, but what did you say "You have to read the file with a UTF-9 capable program"? Is it an error or is it UTF-9 then?

Please Log in to join the conversation.

Moderators: beatnantjciconsultwolvertonkrileon
Time to create page: 0.440 seconds

Facebook Twitter LinkedIn