Error after installation of CB connector

10 years 7 months ago #55265 by rescuediver
geeffland wrote:

Assuming the Forum Path is set correctly it looks likely that you have an older phpbb3 version. This should be used with RC7 or newer... Around RC5 or 6 they modified the password encryption and added the phpbb_hash function.

Greg


I am having a simular problem:
Fatal error: Call to a member function on a non-object in /home/.../public_html/j1013/components/com_comprofiler/plugin/user/plug_cbconnector/plugins/plug_phpbb3.php on line 818

I get this message when trying to view a member's profile. I can view the Admin profile ( Which has not been synced) but if I try to view any other member that has been synced, I get this Message.

I am usig the phpBB3 Gold release, CB1.1 and CBC 2.0.0 Beta.

Post edited by: rescuediver, at: 2008/01/27 06:43
10 years 7 months ago #55327 by geeffland
Is Register Globals set to On...

The following threads discuss this same topic

http://cbconnector.com/forums/viewtopic.php?t=213#1101

http://cbconnector.com/forums/viewtopic.php?t=118#520

Greg

CB3PD Developer - CB Connector (formerly phpBB Connector) plugin
10 years 7 months ago #55353 by rescuediver
Hi,

Thanks for responding... and Yes Register_Globals" is ON and the hosting will not set it to Off. They say it may "break" the others customers websites.

I have tried to comment out the line, but it then gives me another error:
Fatal error: Call to undefined function: setup() in /home/.../public_html/j1013/components/com_comprofiler/plugin/user/plug_cbconnector/plugins/plug_phpbb3.php on line 826

Line 826 Code
$user->setup();
10 years 7 months ago #55408 by geeffland
I think the post I mentioned talks about a change to phpbb3 files? I will double check... basically modified the phpbb3 file (can't remember the name off the top of my head)... to stop it from clearing out those variables.

I will dig more later and post info here...

Greg

CB3PD Developer - CB Connector (formerly phpBB Connector) plugin
10 years 7 months ago #56993 by amutsch
the solution provided to my by my hosting company since their default is register globals on was to create a .htaccess file in the root of my structure for apache to use and if your hosting has php5 installed add this line to that file.

AddType x-mapp-php5 .php

this line will force all .php files to process as php5 and this fixes it as php5 has register global off by default. I have found no adverse effects to this as of yet. This fixed this error and another bug I had on my site
10 years 7 months ago #57066 by geeffland
That should work as well... Also some hosts you can put a php.ini file in the directory turning Register Globals Off...

The following post describes the change you can make in phpbb3 files.

http://cbconnector.com/forums/viewtopic.php?f=10&t=269&view=unread#p1466

Sorry for taking so long to post the URL...
Greg

CB3PD Developer - CB Connector (formerly phpBB Connector) plugin
Moderators: beatnantgeefflandmartijn189krileon
Time to create page: 0.396 seconds
Facebook Twitter Google LinkedIn