Community Builder 2.0 beta 5 released !

5 years 5 months ago #246687 by nant
The following user(s) said Thank You: pepperstreet
5 years 5 months ago #246688 by beat
What a ride!

I'm so happy that we now have the latest and last beta 5 of Community Builder 2.0 available to all our Pro supporters to test and feedback !

Many thanks to Kyle and to Nick for their contributions to CB 2.0. Kyle has done an awesome job styling front-end and backend and fixing bugs and Nick has worked on thousands of language strings to automate the process of getting a full set of language strings, as well as worked on documentation, tests and preparing the releases.

During that time I have worked on finalizing the new architecture and add the compatibility layer so that we should have most if not all CB 1.9.1 CB plugins working on CB 2.0, which is paramount for smooth upgrades.

We are now targetting all our efforts to finish last tasks for upcomming CB 2.0 RC release, and for that we will need your feedbacks on test-installations and upgrades of clones of your real sites, so that we can get a maximum of compatibility and 100% smooth upgrades for RC and stable.

If you upgrade from an earlier 2.0 beta to 2.0 beta 5, you might need to upgrade the site twice to beta 5, in case the first upgrade fails (that is normal for an upgrade between betas, and due to the changes in beta 5 to make it more compatible with 1.9.1 CB Plugins). That won't happen if you upgrade from a CB 1.9.1.

If you upgrade, don't forget to visit our new Tools menu options to upgrade your user profiles to the new canvas layout.

Beat - Community Builder Team Member

Before posting on forums: Read FAQ thoroughly -- Help us spend more time coding by helping others in this forum, many thanks :)
CB links: Our membership - CBSubs - Templates - Hosting - Forge - Send me a Private Message (PM) only for private/confidential info
The following user(s) said Thank You: pepperstreet
5 years 5 months ago #246694 by tjw105
I just installed beta5 (both from upgrade of 1.9.1 and fresh install on Joomla 3.3.1)

After fresh install of Joomla I installed CB 2.0 Beta5

Created the Mandatory User Profile Menu Item

Used the Tools Menu to Load Canvas Layout

This is what I see on the User Profile Page (see attached).

Why am I seeing _UE etc for fields.

Also When I ran the upgrade over my Existing 1.9.1 Install I had to run the upgrade a couple of times. I saw that plugins such as CB AutoActions was in Red.

When CB 2 is Released, Will all of the CB Auto Actions remain and work? I have approx 50 in use at the moment.
Attachments:
5 years 5 months ago #246699 by nant

tjw105 wrote: I just installed beta5 (both from upgrade of 1.9.1 and fresh install on Joomla 3.3.1)

After fresh install of Joomla I installed CB 2.0 Beta5

Created the Mandatory User Profile Menu Item

Used the Tools Menu to Load Canvas Layout

This is what I see on the User Profile Page (see attached).

Why am I seeing _UE etc for fields.

Also When I ran the upgrade over my Existing 1.9.1 Install I had to run the upgrade a couple of times. I saw that plugins such as CB AutoActions was in Red.

When CB 2 is Released, Will all of the CB Auto Actions remain and work? I have approx 50 in use at the moment.


Wow - THANK you for quick testing and feedback.

Yup, it was a bug that crept through and did not install the new language files.

Just download again (new package replacement) and install over and you should be ok.

Regarding your red plugin question, all pre-existing plugins found will be marked as red, but they should work just fine until the new CB 2.0 ones are released.

We have implemented a legacy layer that will support all existing plugins so all CB 191 installs can upgrade and not lose any functionality.

Other team members might chime in here and give more info.
5 years 5 months ago #246700 by beat

tjw105 wrote: I just installed beta5 (both from upgrade of 1.9.1 and fresh install on Joomla 3.3.1)
...
Also When I ran the upgrade over my Existing 1.9.1 Install I had to run the upgrade a couple of times.


Hi tjw105 and thanks for the feedbacks.

That is strange that you had to run it twice to upgrade CB 1.9.1 (while normal for CB 2.0 beta, that shouldn't happen for CB 1.9.1). what happened first time ?

I saw that plugins such as CB AutoActions was in Red.

When CB 2 is Released, Will all of the CB Auto Actions remain and work? I have approx 50 in use at the moment.


Yes, they are in red because of versions mismatch. We will probably make that orange instead of red in RC release, once community tests of beta 5 confirm our compatibility tests.

But as Nick (nant) said, they should still work 100% fine on front-end and fine on backend too.

Please let us know (with exact errors) if you have any issues with any CB plugin so that we can investigate and improve backwards compatibility if needed.

And as said if you or anyone else has issues in CB 1.9.1 to 2.0 beta 5 upgrade in a single installation try, please let us know too. We want to have a polished CB 2.0 for 2.0 RC. :)

Beat - Community Builder Team Member

Before posting on forums: Read FAQ thoroughly -- Help us spend more time coding by helping others in this forum, many thanks :)
CB links: Our membership - CBSubs - Templates - Hosting - Forge - Send me a Private Message (PM) only for private/confidential info
The following user(s) said Thank You: nant, pepperstreet
5 years 5 months ago - 5 years 5 months ago #246701 by Berilac
Having a similar sort of issue with _UE in some fields on members lists being displayed, but my profile page is not being displayed at all. Just a white screen?

Running Joomla 3.3.1 and upgraded from CB2b4 to b5. All was working before as far as I could tell.

Have gone into tools and run the tool checks, throwing uo the following issues:



Checking Community Builder Database:

All Community Builder comprofiler_field_values table fieldid rows all match existing fields.

All Community Builder comprofiler_field_values table rows link to correct fieldtype fields in comprofiler_field table.

All Community Builder fields from comprofiler_fields are present as columns in the comprofiler table.

Checking Community Builder folders:
Avatars and thumbnails folder is Writeable.

All Community Builder _comprofiler_plugin table iscore values are correct.

All Community Builder _comprofiler_tabs table sys values are correct.

All Community Builder _comprofiler_fields table sys values are correct.

Warning: 3 entries in Community Builder _comprofiler_plugin have bad iscore values.

plugin=CB Articles pluginid=536

plugin=CB Blogs pluginid=538

plugin=CB Forums pluginid=543

This one can be fixed by first backing up database then by clicking here.

All Community Builder _comprofiler_tabs table sys values are correct.
All Core CB mandatory basics Database is up to date.

Core CB mandatory basics database checks done. If all lines above are in green, test completed successfully. Otherwise, please take corrective measures proposed in red.
All Core CB Database is up to date.
Click here to Show details



When I click on the link to remedy this I get the following:


SQL error Duplicate entry '17' for key 'PRIMARY' SQL=UPDATE `test_comprofiler_plugin` SET `id` = 17, `iscore` = 1 WHERE `element` = 'cbarticles' AND `iscore` = 0


CBb5 has been installed several times as nant suggested earlier, but nothing seems to solve it?

I am wondering if this package is able to upgrade from b4 already installed. As the instructions suggest an upgrade from 1.9.1?

Have gone into CB backend and unpublished all non core plugins and tabs but that hasnt altered the problem.

Any thoughts would be appreciated.
Moderators: beatnantkrileon
Time to create page: 0.449 seconds

Facebook Twitter LinkedIn