Joomla 3.5 and Community Builder 2.0.14 Released

j35cb2014c

Both PHP7 ready - Joomla 3.5 and Community Builder 2.0.14 are here!

Joomla 3.5 is now available with 34 new features and many bug fixes. But there are also some backwards incompatibilities that could influence upgrades and some third party extensions.

Community Builder 2.0.14 has also been released with new features and bug fixes. CB 2.0.14 is highly recomended for Joomla 3.5 as it addresses a "Failed to start session" error on logout introduced with Joomla 3.5.0.

About Joomla 3.5

The main new features of Joomla 3.5 are:

  • Drag and Drop images in TinyMCE editor
    No need to select and upload images in new editor. Just drag and drop an image from your computer to your editor window.
  • PHP 7 support
    Joomla will now work in PHP 7 environments which may lead to major performance improvements (up to double speed and half memory usage), but a backwards compatibility break had to be introduced to support PHP7.  We believe that this known B/C break will not affect the vast majority of extensions (CB is not affected).
  • Email notifications when new Joomla release is available
    This new feature will send website admins an email notification/reminder when a new release is available.
  • Editor Buttons added to the Toolbar
    You no longer need to scroll down the page to find the “readmore” or “insert image” buttons. Editor extension buttons that used to be placed below the text area can now be found in the toolbar where they belong.
  • Easily Insert Modules in Articles
    This lets you easily add a module into an article with a button directly on the editor toolbar.
  • Item counts in relevant Joomla administrative pages
    This new feature makes is easy to quickly see how many published/unpublished/trashed/archived articles each Joomla category. Similar functionality is also available in Contact, Banner and Newsfeed management pages.
  • User Status admininstrative module improvements
    The Joomla backend pages have a fixed footer strip with some useful info and links about your website. You now have more control on what is displayed.
  • Download system/environment info for support cases
    Help support teams to help you by including your website system information using this new functionality.
  • User CSS file for Protostar template
    No more hacking needed to add your extra css code in Joomla's Protostar template. You can now add your user.css file and it will be loaded.
  • Statistics gathering for Joomla usage
    Joomla 3.5's new statistics collection plug-in gathers the system environment in use. The raw data collected is anonymised before transmission and access to the compiled data is publicly available.

In addition to these features Joomla 3.5 has also fixes over 650 bugs.

So the $64K question ... what to do .. upgrade or wait?

As there are no reported high or medium level security issues, there is no security related need to rush and upgrade.

Some may choose to wait a few days (or maybe even for next Joomla 3.5.1) and others may choose to upgrade to Joomla 3.5.  But before upgrading your live sites you should follow the following 3-step guidelines:

  1. Check all thrid-party extensions you have installed on your website and check for Joomla 3.5 compatibility reassurance. If needed install new releases when available.
  2. Clone your website and perform that upgrade to Joomla 3.5 on the cloned environment and test everything before you updrage your live sites.
  3. Always backup your live site before you upgrade, just in case something goes wrong and you need to revert things.

About Community Builder 2.0.14

Community Builder 2.0.14 is here with 3 new features and 13 bug fixes. It also addresses a Joomla 3.5 backwards compatibility issue that caused an error during frontend logout.

The full CB 2.0.14 changelog is available in the forum discussion. CB 2.0.14 can be easily installed over any existing CB 2.0+ environment and will continue to work on Joomla 3.4.8 environments (in addition to the just released Joomla 3.5).

Please note that CB 2.0.14 continues to work just fine an older PHP versions (PHP 5.3.3 and greater).

Discuss this article on our forums.

Facebook Twitter Google LinkedIn