"New" Payment Gateway fails

11 years 4 months ago #138585 by tbigelow51
"New" Payment Gateway fails was created by tbigelow51
When I go to Payment Gates and click "New", I get the following error:

Warning: Parameter 1 to cbpaidGatewayAccountMgr::gatewayAccountObjects() expected to be a reference, value given in C:\xampp\htdocs\papoh\components\com_comprofiler\plugin\user\plug_cbpaidsubscriptions\cbpaidsubscriptions.sql.php on line 0
showview::sql:row: load failed: DB function reports no errors

In my search I find that CBSubs 1.0.3 does not support PHP 5.3, and thus the error. Is this correct?

Since I am trying to put this together on XAMPP which has PHP 5.3.1, how do I get around this?

Post edited by: tbigelow51, at: 2010/07/24 05:16

Please Log in to join the conversation.

11 years 4 months ago #138593 by nant
Replied by nant on topic Re:
tbigelow51 wrote:

When I go to Payment Gates and click "New", I get the following error:

Warning: Parameter 1 to cbpaidGatewayAccountMgr::gatewayAccountObjects() expected to be a reference, value given in C:\xampp\htdocs\papoh\components\com_comprofiler\plugin\user\plug_cbpaidsubscriptions\cbpaidsubscriptions.sql.php on line 0
showview::sql:row: load failed: DB function reports no errors

In my search I find that CBSubs 1.0.3 does not support PHP 5.3, and thus the error. Is this correct?

Since I am trying to put this together on XAMPP which has PHP 5.3.1, how do I get around this?

Post edited by: tbigelow51, at: 2010/07/24 05:16


Yes this is the issue - CBSubs does not work on PHP 5.3 yet (CBSubs 1.1 in testing does).

Your option:
+ Download a new XAMPP package with earlier PHP support.

Please Log in to join the conversation.

11 years 3 months ago #139511 by info@aifci.co.uk
Replied by info@aifci.co.uk on topic Re:"New" Payment Gateway fails
I have only just purchased the new version of CB Subs I understood that this error would be rectified in this version and that PHP 5.3 would be supported yet when I tried to create a new payment gateway i was confronted with the following error;

showview::sql:row: load failed: DB function reports no errors

I am new to joomla and so any advice you give would have to be in the style of dealing with a village idiot

Thanks

Please Log in to join the conversation.

11 years 3 months ago #139523 by nant
Replied by nant on topic Re:
info@aifci.co.uk wrote:

I have only just purchased the new version of CB Subs I understood that this error would be rectified in this version and that PHP 5.3 would be supported yet when I tried to create a new payment gateway i was confronted with the following error;

showview::sql:row: load failed: DB function reports no errors

I am new to joomla and so any advice you give would have to be in the style of dealing with a village idiot

Thanks


First thing would be to ask your host if it is possible to operate on a PHP 5.2 version (most hosts typically have such an option).

Please Log in to join the conversation.

11 years 3 months ago #140027 by henrykk
Replied by henrykk on topic Re:
I am encountering the same issue:

when I create new sub plan:
showview::sql:row: load failed: DB function reports no errors

I am running
MySQL: 5.1.41-3ubuntu12.6
php 5.3.2-1ubuntu4.2

Are there any work rounds or patches - This is an urgent development.

With thanks

Please Log in to join the conversation.

11 years 3 months ago #140028 by nant
Replied by nant on topic Re:
No workaround.
It will be addressed properly with the release of CBSubs 1.1 which is currently in RC2 phase in test team.

You should ask your host if a PHP 2.X environment is available or you should downgrade if working on a local xampp environment.

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.181 seconds

Facebook Twitter LinkedIn