There are duplicate header variables error message

9 years 4 months ago - 9 years 4 months ago #166701 by NicoFaaij
Hi CB-friends,

CB Juice doesn't work at my site. At import it gives my the message:
"There are duplicate header variables which is not allowed."?

I use Joomla 1.6.3 and CB 1.4 and CB Juice2 2.0.2.

Does anybody have a clue why I get this error message? See the output below.

Starting an ADD-EDIT Run in CBJUICE2

CB Version =1.4
CBJ2_HEADER_VARIABLES are
Array ( [0] => name [1] => [2] => username [3] => [4] => email [5] => [6] => password [7] => [8] => block [9] => [10] => sendEmail [11] => [12] => registerDate [13] => [14] => lastvisitDate [15] => [16] => activation [17] => [18] => params [19] => [20] => firstname [21] => [22] => middlename [23] => [24] => lastname [25] => [26] => hits [27] => [28] => message_last_sent [29] => [30] => message_number_sent [31] => [32] => avatar [33] => [34] => avatarapproved [35] => [36] => approved [37] => [38] => confirmed [39] => [40] => lastupdatedate [41] => [42] => registeripaddr [43] => [44] => cbactivation [45] => [46] => banned [47] => [48] => banneddate [49] => [50] => unbanneddate [51] => [52] => bannedby [53] => [54] => unbannedby [55] => [56] => bannedreason [57] => [58] => acceptedterms [59] => [60] => cb_profilechoose [61] => [62] => cb_goal [63] => [64] => cb_typedeelname [65] => [66] => cb_steunmij [67] => [68] => cb_profiletype [69] => [70] => bfdFeedURL [71] => [72] => mfdFeedURL [73] => [74] => twUsername [75] => [76] => geoLat [77] => [78] => geoLng [79] => [80] => cb_zipcode [81] => [82] => cb_ikdoemeeomdat [83] => [84] => cb_mijnactie [85] => [86] => cb_myblog [87] => [88] => cb_mijnhyves [89] => [90] => cb_opfacebook [91] => [92] => cb_mijnlinkedin [93] => [94] => cb_mijnpersoonlijkesite [95] => [96] => cb_teamnaam [97] => [98] => cb_plfile [99] => [100] => cb_maatbroek [101] => [102] => cb_maatshirt [103] => [104] => cb_accomodatie [105] => [106] => cb_tussenstand [107] => [108] => usertype )
There are duplicate header variables which is not allowed.
Array ( [name] => 1 [] => 54 [username] => 1 => 1 [password] => 1 [block] => 1 [sendEmail] => 1 [registerDate] => 1 [lastvisitDate] => 1 [activation] => 1 [params] => 1 [firstname] => 1 [middlename] => 1 [lastname] => 1 [hits] => 1 [message_last_sent] => 1 [message_number_sent] => 1 [avatar] => 1 [avatarapproved] => 1 [approved] => 1 [confirmed] => 1 [lastupdatedate] => 1 [registeripaddr] => 1 [cbactivation] => 1 [banned] => 1 [banneddate] => 1 [unbanneddate] => 1 [bannedby] => 1 [unbannedby] => 1 [bannedreason] => 1 [acceptedterms] => 1 [cb_profilechoose] => 1 [cb_goal] => 1 [cb_typedeelname] => 1 [cb_steunmij] => 1 [cb_profiletype] => 1 [bfdFeedURL] => 1 [mfdFeedURL] => 1 [twUsername] => 1 [geoLat] => 1 [geoLng] => 1 [cb_zipcode] => 1 [cb_ikdoemeeomdat] => 1 [cb_mijnactie] => 1 [cb_myblog] => 1 [cb_mijnhyves] => 1 [cb_opfacebook] => 1 [cb_mijnlinkedin] => 1 [cb_mijnpersoonlijkesite] => 1 [cb_teamnaam] => 1 [cb_plfile] => 1 [cb_maatbroek] => 1 [cb_maatshirt] => 1 [cb_accomodatie] => 1 [cb_tussenstand] => 1 [usertype] => 1 )[/i] The header line from my import file is: [i]"name"~~"username"~~"email"~~"password"~~"block"~~"sendEmail"~~"registerDate"~~"lastvisitDate"~~"activation"~~"params"~~"firstname"~~"middlename"~~"lastname"~~"hits"~~"message_last_sent"~~"message_number_sent"~~"avatar"~~"avatarapproved"~~"approved"~~"confirmed"~~"lastupdatedate"~~"registeripaddr"~~"cbactivation"~~"banned"~~"banneddate"~~"unbanneddate"~~"bannedby"~~"unbannedby"~~"bannedreason"~~"acceptedterms"~~"cb_profilechoose"~~"cb_goal"~~"cb_typedeelname"~~"cb_steunmij"~~"cb_profiletype"~~"bfdFeedURL"~~"mfdFeedURL"~~"twUsername"~~"geoLat"~~"geoLng"~~"cb_zipcode"~~"cb_ikdoemeeomdat"~~"cb_mijnactie"~~"cb_myblog"~~"cb_mijnhyves"~~"cb_opfacebook"~~"cb_mijnlinkedin"~~"cb_mijnpersoonlijkesite"~~"cb_teamnaam"~~"cb_plfile"~~"cb_maatbroek"~~"cb_maatshirt"~~"cb_accomodatie"~~"cb_tussenstand"~~"usertype"[/i] Many thanks in advance because this is almost driving me crazy :-( Nico[email] => 1 [password] => 1 [block] => 1 [sendEmail] => 1 [registerDate] => 1 [lastvisitDate] => 1 [activation] => 1 [params] => 1 [firstname] => 1 [middlename] => 1 [lastname] => 1 [hits] => 1 [message_last_sent] => 1 [message_number_sent] => 1 [avatar] => 1 [avatarapproved] => 1 [approved] => 1 [confirmed] => 1 [lastupdatedate] => 1 [registeripaddr] => 1 [cbactivation] => 1 [banned] => 1 [banneddate] => 1 [unbanneddate] => 1 [bannedby] => 1 [unbannedby] => 1 [bannedreason] => 1 [acceptedterms] => 1 [cb_profilechoose] => 1 [cb_goal] => 1 [cb_typedeelname] => 1 [cb_steunmij] => 1 [cb_profiletype] => 1 [bfdFeedURL] => 1 [mfdFeedURL] => 1 [twUsername] => 1 [geoLat] => 1 [geoLng] => 1 [cb_zipcode] => 1 [cb_ikdoemeeomdat] => 1 [cb_mijnactie] => 1 [cb_myblog] => 1 [cb_mijnhyves] => 1 [cb_opfacebook] => 1 [cb_mijnlinkedin] => 1 [cb_mijnpersoonlijkesite] => 1 [cb_teamnaam] => 1 [cb_plfile] => 1 [cb_maatbroek] => 1 [cb_maatshirt] => 1 [cb_accomodatie] => 1 [cb_tussenstand] => 1 [usertype] => 1 )


The header line from my import file is:
"name"~~"username"~~"email"~~"password"~~"block"~~"sendEmail"~~"registerDate"~~"lastvisitDate"~~"activation"~~"params"~~"firstname"~~"middlename"~~"lastname"~~"hits"~~"message_last_sent"~~"message_number_sent"~~"avatar"~~"avatarapproved"~~"approved"~~"confirmed"~~"lastupdatedate"~~"registeripaddr"~~"cbactivation"~~"banned"~~"banneddate"~~"unbanneddate"~~"bannedby"~~"unbannedby"~~"bannedreason"~~"acceptedterms"~~"cb_profilechoose"~~"cb_goal"~~"cb_typedeelname"~~"cb_steunmij"~~"cb_profiletype"~~"bfdFeedURL"~~"mfdFeedURL"~~"twUsername"~~"geoLat"~~"geoLng"~~"cb_zipcode"~~"cb_ikdoemeeomdat"~~"cb_mijnactie"~~"cb_myblog"~~"cb_mijnhyves"~~"cb_opfacebook"~~"cb_mijnlinkedin"~~"cb_mijnpersoonlijkesite"~~"cb_teamnaam"~~"cb_plfile"~~"cb_maatbroek"~~"cb_maatshirt"~~"cb_accomodatie"~~"cb_tussenstand"~~"usertype"

Many thanks in advance because this is almost driving me crazy :-(

Nico

Please Log in to join the conversation.

9 years 4 months ago - 9 years 4 months ago #166836 by wolverton
Try changing delimiter to the default comma or just one tilde.
Looks like you have set the delimiter as ~, but you have ~~ between each header name.
CBJuice is seeing a blank header between the adjacent tildes, for a count of 54 blank headers .

Please Log in to join the conversation.

9 years 4 months ago - 9 years 4 months ago #166952 by NicoFaaij
Thank you Wolverton! It didn't work directly but I think you are right that was the biggest mistake from my. I was a little too cautious ;-).

It took me some more hours because there where more problems like bellow, but now I finally imported the users.

- not existing headers in my new website
- the export didn't do his job correctly on fields with a lot of html data in it, so I had to do some spreadsheet editting on the export and that fields I had to cut and past manually in PHPmyAdmin.

Still have one problem, my user-id's are changed and these user-id's are automatically connected to my bookkeeping system. I will make a separete forum subject for that issue.

Please Log in to join the conversation.

9 years 4 months ago #166961 by jciconsult
Moving from 1.5 to 1.6 is a complicated issue. When you use CBJUICE, you are essentially moving data to create a new site. I have been experimenting with using the upgrade component to create a new site with an appropriate users table. The goal is to preserve userids. The next stage is to move cb using cbjuice if necessary. However, if you are comfortable with phpmyadmin, just moving tables if you manage to preserve the userids is not that difficult. CBJUICE might be used to move specific parts of CB as appropriate.
In terms of HTML fields with CBJUICE, there will be problems with embedded carriage returns or line feeds. CBJUICE2 should manage that better than our origiginal version. I recommend using CBJ2 on both the exporting and importing site for that reason.

Please Log in to join the conversation.

9 years 4 months ago #166963 by NicoFaaij
Thanks jciconsult for your quick responce!

I do use the latest JBJuice2 version for my export from Joomla 1.5.20-Legacy / CB 1.2.3 sites to the new Joomla 1.6.3 / CB 1.4.

But that still gives my a lot of problems with the fields with html-code which are not correctly exported and split across multiple colums.

I have managed to use CBJuice with some manual cut and paste for the first 40 users. They are now automatically created but with new user-id's (Because in the old site a lot of first users were deleted in the past)

The new site is not a migration but a totally new site, where I have created the same CB fieldnames.

I am not comfortable with phpmyadmin but I can coppy the 3 fields from the 250 users by hand if I have to.

For the user-id I have made a general CB topic https://www.joomlapolis.com/forum/146-general/166958-can-i-change-the-joomlacb-userids

Do you say that I can just change the user-id's on the jos_comprofiler and jos_users or is there also a link to other places in the database?

Thanks again,
Nico

Please Log in to join the conversation.

9 years 4 months ago #166976 by jciconsult
The problem with HTML fields comes if you open the file in Excel. Excel causes the split across multiple columns. YOu may have better luck with Libre Office or just not open the file before you upload it.

There is no easy way to force the creation of users with specific ids with significantly hacking some program.

Unless you are serious familiar with phpmyadmin and the complete structure of joomla and any components that you have added, I would not attempt to do things. You might be getter off to write an edit function to update your book keeping links.

Please Log in to join the conversation.

Moderators: beatnantjciconsultwolvertonkrileon
Time to create page: 0.407 seconds

Facebook Twitter LinkedIn