Error updating from CB 2.5.0 to latest

4 months 1 week ago #336561 by jwarcher
Error updating from CB 2.5.0 to latest was created by jwarcher
Tried to update from Web from within Joomla to get a badly outdated install updated. Got the message below. 

Any help would be greatly appreciated. Thanks! 

System Information
Joomla: 3.9.8
Community Builder: 2.5.0
PHP: 7.3.33
Database: mysql 8.0.28-0ubuntu0.20.04.3

Package
File: 000_pkg_communitybuilder_2.9.1+build.2023.12.19.18.36.55.b65c99514.zip
Log:
Call to undefined method CBLib\Input\Input::getCmd()

Please Log in to join the conversation.

4 months 1 week ago #336562 by beat
Replied by beat on topic Error updating from CB 2.5.0 to latest
Did you try to upgrade a second time ?

Very old versions might need 2 attempts depending on situation.

Or you may try to go through intermediate CB version 2.6.4 (which supports PHP 5.6.40-8.0.x) to bridge the gap of PHP versions supported since CB 2.5.

To download the 2.6.4 installer, select 2.6.4+2021.11.03... from drop-down menu in our Downloads section (Downloads top menu of this site)

Beat - Community Builder Team Member

Before posting on forums: Read FAQ thoroughly -- Help us spend more time coding by helping others in this forum, many thanks :)
CB links: Our membership - CBSubs - Templates - Hosting - Forge - Send me a Private Message (PM) only for private/confidential info

Please Log in to join the conversation.

4 months 1 week ago #336563 by jwarcher
Replied by jwarcher on topic Error updating from CB 2.5.0 to latest
Thanks for the reply!

I went back and tried another install attempt and it still failed. 

Then downloaded the 2.6.4 version you referenced, but that also failed (twice). 

What's my next move? 

Please Log in to join the conversation.

4 months 1 week ago #336576 by krileon
Replied by krileon on topic Error updating from CB 2.5.0 to latest
It's erroring on a CB function during the installer process. Try downloading manually from our downloads page below and installing through Joomla extension manager instead of CB and it will use Joomla's API instead. If issue persists unzip the package and install CB directly through Joomla extension manager from the /extensions/packages folder to bypass our installer.

www.joomlapolis.com/downloads


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

4 months 6 days ago #336609 by jwarcher
Replied by jwarcher on topic Error updating from CB 2.5.0 to latest
I was able to update to 2.6.4 using the Joomla extension manager. Thank you for that!

I can't update to CB 2.9.1 because I'm still on Joomla 3.9.8, according to error message that was thrown. Message says minimum Joomla version is 3.10. My Joomla back-end doesn't show any updates available. 

My real problem is that emails from CB aren't working at all. I was hoping upgrading could fix this. Do you have other pointers on how to fix email problems? They were working fine until a couple months ago. Thanks! 

Please Log in to join the conversation.

4 months 6 days ago #336610 by jwarcher
Replied by jwarcher on topic Error updating from CB 2.5.0 to latest
Okay, nevermind, got Joomla updated to 3.10.2 and CB updated to 2.9.1. Thanks! 

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.216 seconds

Facebook Twitter LinkedIn