Error on new user confirmation

4 months 2 weeks ago - 4 months 2 weeks ago #335411 by The Donald
Error on new user confirmation was created by The Donald
Hello,
I recently moved my site from Joomla 3 to Joomla 4 and everything went well. However I am seeing the below error when I try to approve a new user. All other aspects of the registration process are working normally, and I can go into manage user and approve the user. The error occurs when I approve the user from the front end. I have included the error report.

Appreciate any help you can provide.0 count(): Argument #1 ($value) must be of type Countable|array, null given
Callstack#FunctionLocation
1()JROOT/components/com_comprofiler/comprofiler.php:1892
2approveUser()JROOT/components/com_comprofiler/comprofiler.php:222
3require_once()JROOT/libraries/src/Dispatcher/LegacyComponentDispatcher.php:71
4Joomla\CMS\Dispatcher\LegacyComponentDispatcher::Joomla\CMS\Dispatcher\{closure}()JROOT/libraries/src/Dispatcher/LegacyComponentDispatcher.php:73
5Joomla\CMS\Dispatcher\LegacyComponentDispatcher->dispatch()JROOT/libraries/src/Component/ComponentHelper.php:361
6Joomla\CMS\Component\ComponentHelper::renderComponent()JROOT/libraries/src/Application/SiteApplication.php:208
7Joomla\CMS\Application\SiteApplication->dispatch()JROOT/libraries/src/Application/SiteApplication.php:249
8Joomla\CMS\Application\SiteApplication->doExecute()JROOT/libraries/src/Application/CMSApplication.php:293
9Joomla\CMS\Application\CMSApplication->execute()JROOT/includes/app.php:6110require_once()JROOT/index.php:32

Please Log in to join the conversation.

4 months 2 weeks ago #335423 by krileon
Replied by krileon on topic Error on new user confirmation
Only way I can see that happening is if you pressed the approve button without having any users selected.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

4 months 2 weeks ago #335431 by The Donald
Replied by The Donald on topic Error on new user confirmation
Yup! You are correct. Thanks for this! Probably shouldn't work on my website late at night!

 

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.178 seconds

Facebook Twitter LinkedIn