[#8215] declare class PEAR

4 months 1 week ago - 4 months 1 week ago #321123 by galanopd
[#8215] declare class PEAR was created by galanopd
It seems that there is an issue during installation of the new version of CB when there is CVCRM already installed (declare class PEAR).

Attachments:

Please Log in to join the conversation.

4 months 1 week ago #321139 by krileon
Replied by krileon on topic declare class PEAR
Strange, shouldn't happen if both implementations are using an autoloader which CB certainly uses. Is that the full callstack for that error?


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

4 months 1 week ago #321144 by galanopd
Replied by galanopd on topic declare class PEAR
Yes, it is. No other error or anything.

I have also updated CiviCRM with a patch they released 6 days ago from 5.30.0 to 5.30.1 and then tried to reinstall CB but no success again!

I have installed CB on another website without the presence of CiviCRM and I had no issues.

I don't kow what can be wrong. I have updated everything, now I am using

CB 2.4.6+build.2020.10.21.15.46.58.5c8f79e2a
CiviCRM 5.30.1
Joomla 3.9.22
Wamp 3.2.3
Apache 2.4.46a
PHP 7.4.11
MariaDB 10.4.12

Thanks

Please Log in to join the conversation.

4 months 1 week ago #321147 by krileon
Replied by krileon on topic declare class PEAR
Have added a bug ticket and will investigate further for a future release. For now best I can suggest is disable CIVICRM before updating CB to prevent the conflict.

forge.joomlapolis.com/issues/8215


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
The following user(s) said Thank You: galanopd

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.449 seconds

Facebook Twitter LinkedIn