User did not receive confirmation hyperlink when registering

2 months 3 weeks ago #326282 by Ake2017
Hi,

A user registered and then received an e-mail for confirmation of the users e-mail address.

Subject line: Your sign up request is pending approval
Content: "Thank you for signing up with us. We have received your request and we will process it as soon as you confirm your email address by clicking on the following hyperlink:
Once your email address is confirmed our moderators...etc"

However - as seen above, no hyperlink was included in the e-mail. What could be the reason for that?

Anyway, I did receive an e-mail with the subject line "Sign Up" and the content "A new user has signed up at www.handix.se and requires approval.
This email contains their details... etc" so no real harm done.

But I am still wondering what I could do to make it work better.

Kind regards

Please Log in to join the conversation.

2 months 3 weeks ago #326299 by krileon
Did you modify "Pending Email Body" within CB > Configuration > Registration or is it still set to its default value of YOUR_REGISTRATION_IS_PENDING_APPROVAL_MESSAGE? If you modified the parameter it just sounds like you're missing [CONFIRM] substitution.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

2 months 3 weeks ago #326306 by Ake2017
No. It is still set to the default value.

Please Log in to join the conversation.

2 months 2 weeks ago #326314 by krileon
Strange, there shouldn't be any reason for the link to be missing. Maybe your email provider is filtering it out for some reason? Do you have a different email domain you can try (e.g. if not working with yahoo try gmail)? Note it's only going to have the confirmation link if you have email confirmation enabled in CB > Configuration > Registration.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

2 months 2 weeks ago #326339 by Ake2017
Well, since the e-mail specifically refers to the link, I believe that it proves that I have enabled that function.
SO, I still do not understand why the recipient did not receive the link.
(I see no reason why either the sending party (my host) or the receiving part (my visitors e-mail) should filter out a specific link)

Please Log in to join the conversation.

2 months 2 weeks ago #326362 by krileon
The following can result in it being missing.

1. Email confirmation isn't turned on in CB > Configuration > Registration
2. Their cbactivation database column is empty (activation code) for some reason
3. The language string was overridden and [CONFIRM] wasn't included in the override
4. Their email provider or yours is filtering out the link.

For #1 simply review your configuration carefully. For #2 that'd have to be something installed breaking CB user storage. For #3 edit your default language plugin in CB > Plugin Management and under Overrides see if you're overriding YOUR_REGISTRATION_IS_PENDING_APPROVAL_MESSAGE language key. For #4 test with different email domains to see if they all are missing the link.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.194 seconds

Facebook Twitter LinkedIn