Emails to users not send by CBPHPMailer

4 months 4 weeks ago #330655 by QEmiel
Hi,
CB is using CBLib/CBphpMailer for sending notification mails to registered users and admin. The current version is v5.2.28 which seems not to be compatible anymore at Joomla 4.2.2 (PHP 8.0.21) as to be sent emails are not received.
The Vendor/PHPMailer is working fine (see attached mail log). Can you please update the PHPMailer to v6.6.0?

Thx. 

File Attachment:

File Name: php-mail.log.txt
File Size:3 KB
Attachments:

Please Log in to join the conversation.

4 months 4 weeks ago #330656 by krileon
Replied by krileon on topic Emails to users not send by CBPHPMailer
Our mailer works fine with PHP 8.0. You likely have a different issue preventing it from working. It's tested working up to PHP 8.1. Joomla version is of no concern for our mailer as it's an independent PHPMailer build that has been manually patched. There are plans to remove it though. Try sending an email to yourself in CB > User Management using the Mass Mailer button and see if it errors.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

4 months 4 weeks ago #330657 by QEmiel
Replied by QEmiel on topic Emails to users not send by CBPHPMailer
Thx for your quick reply!
Just test the CB mass mailer (allowed in global configuration): according CB messages have been sent (see attachment)  , however no emails were received.
Attachments:

Please Log in to join the conversation.

4 months 4 weeks ago #330659 by krileon
Replied by krileon on topic Emails to users not send by CBPHPMailer
If it's not reporting any errors the email is being stopped either by your mail server or by the email provider you're sending the email to. If you supplied a from address in CB > Configuration > Registration ensure the email address is correct and allowed to send emails from your mail server otherwise empty it and it'll fallback to Joomla default from address.

Are you using PHP Mailer or SMTP in Joomla mailer configuration?


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

4 months 4 weeks ago #330660 by QEmiel
Replied by QEmiel on topic Emails to users not send by CBPHPMailer
I'am using the setting PHP mailer in the global configuration. AcyMailing and JEvents mails and notification are succesfull, so It seems not to be the mail server at the provider?

Please Log in to join the conversation.

4 months 4 weeks ago #330662 by krileon
Replied by krileon on topic Emails to users not send by CBPHPMailer
Did you check the from address parameter in CB > Configuration > Registration? That's used for all of CBs emails unless empty then it will fallback to whatever is set in Joomla.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.203 seconds

Facebook Twitter LinkedIn