Emails to users not send by CBPHPMailer

4 months 4 weeks ago #330664 by QEmiel
Replied by QEmiel on topic Emails to users not send by CBPHPMailer
Please see attaches screenshots   
Attachments:

Please Log in to join the conversation.

4 months 4 weeks ago #330665 by krileon
Replied by krileon on topic Emails to users not send by CBPHPMailer
Clear the reply-to address and retry.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

4 months 4 weeks ago #330666 by QEmiel
Replied by QEmiel on topic Emails to users not send by CBPHPMailer
Just retried to sent by use of the mass mailer, no incoming messages.
The PHP mailer test from within the global configuration is OK.
Attached the PHP mailer settings in the global config and the CB pages setting general and registration for your info.
I hope it helps..     
Attachments:

Please Log in to join the conversation.

4 months 4 weeks ago #330667 by krileon
Replied by krileon on topic Emails to users not send by CBPHPMailer
If the mailer isn't erroring it's being stopped at the mail server not in PHP. Am looking into removing our PHPMailer as it's a bit of a leftover from Joomla 1.x days that we don't really need anymore. I do not have a timeframe when that will be done. I suggest contacting your host and seeing if they can check mailer logs. It's possible your host might also recommend SMTP over PHP Mail. I don't have anything further to suggest at this time.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
The following user(s) said Thank You: QEmiel

Please Log in to join the conversation.

4 months 3 weeks ago #330697 by QEmiel
Replied by QEmiel on topic Emails to users not send by CBPHPMailer
Support from my provider confirmed no issues with the PHP mail server and replied the bug could be caused by the update of the PHP version 8.0
As the PHP mailer 6.6.0 (used by other extensions) is working fine, would it be possible to reroute the settings in CB configuration for use of the other PHP mailer?

Please Log in to join the conversation.

4 months 3 weeks ago #330698 by krileon
Replied by krileon on topic Emails to users not send by CBPHPMailer
It's not caused by PHP 8. My development environment has been PHP 8.1 for months and 8.0 for months prior to that where the email is working perfectly fine. You can try using SMTP within Joomla's mailer settings and CB will use that as well. There is not a way to configure CBs mailer separately.

I've already a pending merge request to switch CBs mailer entirely over to Joomla's. Once reviewed and merged (we use peer review in our team) there won't be a CBPHPMailer anymore. This likely won't be until sometime next week as Beat is taking some well deserved rest this week.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
The following user(s) said Thank You: QEmiel

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.188 seconds

Facebook Twitter LinkedIn