[SOLVED] Problem with CB email sending

2 months 4 weeks ago - 2 months 4 weeks ago #331476 by tetronik
[SOLVED] Problem with CB email sending was created by tetronik
Yesterday, a person trying to register on our site through the CB sign-up form sent me a message that, at the end of the registration process, he was getting the following error message (see also attached):

0 Return value of CBLib\Cms\Joomla\Joomla4::getMailer() must be an instance of Joomla\CMS\Mail\Mail, instance of JMail returned

Additionally he did not receive an email confirmation, presumably because CB is no longer able to send mails due to the above error. What strikes me the most is the "Joomla4" element in the error message, since our site is still using Joomla 3 (V3.10.11). The latest version of CB (2.7.4+build.2022.10.21.15.41.28.56bdcdeab) is already installed.

Any ideas how this problem might be fixed? Your help is much appreciated.
Attachments:

Please Log in to join the conversation.

2 months 4 weeks ago #331483 by krileon
Replied by krileon on topic Problem with CB email sending
Strange, JMail is just an alias for Joomla\CMS\Mail\Mail so that should not be erroring. Also works fine in my tests. What PHP version are you on?


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

2 months 4 weeks ago #331484 by krileon
Replied by krileon on topic Problem with CB email sending
Am also preemptively applying a fix. Normally an alias like that should work fine, but it might not under some PHP versions.

forge.joomlapolis.com/issues/9068


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

2 months 4 weeks ago #331485 by tetronik
Replied by tetronik on topic Problem with CB email sending
Thanks for your quick reply!
My PHP version is admittedly a "little" outdated... it's 7.4.30. You think updating to a newer PHP version might resolve the issue?
I'll try that. Thanks for the hint!

Please Log in to join the conversation.

2 months 4 weeks ago #331487 by tetronik
Replied by tetronik on topic Problem with CB email sending
Thank you for that, too!

I just tried upgrading to a higher/newer PHP version on my test system (PHP 8.0.23 and then PHP 8.1.10). But in both cases I got the following error message on my Joomla backend:

0 Call to undefined function create_function()

Please Log in to join the conversation.

2 months 4 weeks ago #331489 by krileon
Replied by krileon on topic Problem with CB email sending
Check within your server error logs and provide the full callstack for that error. We do have some plugins using create_function if it's available and only on older PHP versions, but if you've a really old version of a plugin installed that's using it then it's probably not compatible with your PHP version.

PHP 7.4 should be working fine though so you shouldn't have to upgrade to PHP 8 and it's not really recommended while still on Joomla 3.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.236 seconds

Facebook Twitter LinkedIn