Administrator does not receive new registration notifications

1 year 1 month ago #310958 by westwing
Hello,

This worked well until 3 days ago. I'm using CB 2.4 and Joomla 3.9.1 which was upgraded to 3.9.3 today to see if this helped.

If I register as a new user, I (the new user) receive the email telling me my registration is pending but the administrator no longer does.

No settings have changed that I can see.

Moderators View Access Level is set to Super Users
Moderator Approve Users is set to yes
Send Moderators Email is set to yes
If I go to CB users Mass Mailer I can send a message to the administrator.
The normal Joomla contact form works fine
I have tried CB Tools Synchronize Users

I have even made a New User Group with full rights .... I tried this too but nothing.

Any thoughts? Remember, this WAS working fine until a few days ago. Its not spam marking either as the domain is whitelisted and I can monitor my email servers output .....
1 year 1 month ago #310974 by krileon
Edit your moderator user within CB > User Management and ensure they're configured to receive emails. Not really any reason for this to stop working suddenly by updating Joomla. Nothing regarding the email API was changed recently in CB it self.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
3 months 3 weeks ago #315806 by wilburg
I also am having trouble receiving registration emails. My user account has "Receive Moderator Emails" set to yes.
3 months 3 weeks ago #315807 by wilburg
I should note that the newly registered user is receiving the notification that his application must be approved. However, my administrative email is not receiving the notification of his registration, nor is there any user approval appearing in that CB menu item.
3 months 3 weeks ago #315834 by krileon
Doesn't sound like your user has CB Moderator permissions then. They should have a usergroup that's within your Moderator View Access Level, which is configured in CB > Configuration > Moderation. Again, none of this has been changed so you've changed something within your install recently; likely entirely due to that ACL parameter. You should see a link regarding pending approvals within your CB Workflows module if you've permission to approve users from frontend.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
Moderators: beatnantkrileon
Time to create page: 0.430 seconds

Facebook Twitter LinkedIn