[SOLVED] Unable to create new user in CB backend

3 months 2 weeks ago - 3 months 2 weeks ago #315947 by Kampp

nant wrote:

Kampp wrote: What field are you talking about? Can't see that it is mentioned what field it is.

DateTime::__construct(): Failed to parse time string (99-99-9999) at position 0 (9): Unexpected character


That is the error, not what CB field it is related to?

Also why is this not an issue when editing?

Creator of the CB plugins: "User IP log" and "Public Mail"
Joomla! services/coding: www.toolmaster.dk
Danish Joomla! hosting: www.joomla-hosting.dk
3 months 1 week ago #315956 by krileon

What field are you talking about? Can't see that it is mentioned what field it is.

Based off the error callstack it's failing inside of a Date or DateTime fieldtype. Review your Date and DateTime fields within CB > Field Management. Are you supplying a custom date format for any of them? Was not able to confirm your issue locally so it's likely a specific configuration of some kind causing your issue. It could even be the "Default Registration Value" parameter if an invalid value is supplied.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
The following user(s) said Thank You: nant
3 months 1 day ago - 3 months 1 day ago #316064 by Kampp

krileon wrote:

What field are you talking about? Can't see that it is mentioned what field it is.

Based off the error callstack it's failing inside of a Date or DateTime fieldtype. Review your Date and DateTime fields within CB > Field Management. Are you supplying a custom date format for any of them? Was not able to confirm your issue locally so it's likely a specific configuration of some kind causing your issue. It could even be the "Default Registration Value" parameter if an invalid value is supplied.


This did indeed fix it. 9999-99-99 was set as default value in a date type field. Thanks

Creator of the CB plugins: "User IP log" and "Public Mail"
Joomla! services/coding: www.toolmaster.dk
Danish Joomla! hosting: www.joomla-hosting.dk
The following user(s) said Thank You: krileon
Moderators: beatnantkrileon
Time to create page: 0.413 seconds

Facebook Twitter LinkedIn