[#4128] comprofiler-table reaches maximum database-fields

7 years 2 months ago - 7 years 2 months ago #231350 by rosshennessy
Hi,

I have a lot of fields in the Community Builder 1.9 Fields.

When I try to add one more I get this error:

moscomprofilerFields::store failed: CBSQLupgrader::changeColumn (ADD) of Table #__comprofiler Column cb_test12 failed with SQL error: Row size too large. The maximum row size for the used table type, not counting BLOBs, is 65535. You have to change some columns to TEXT or BLOBs SQL=ALTER TABLE `blu_comprofiler`\n ADD `cb_test12` varchar(255) DEFAULT NULL Row size too large. The maximum row size for the used table type, not counting BLOBs, is 65535. You have to change some columns to TEXT or BLOBs SQL=ALTER TABLE `blu_comprofiler`\n ADD `cb_test12` varchar(255) DEFAULT NULL

Is there a way to have unlimited fields.

Thanks

Please Log in to join the conversation.

7 years 2 months ago #231355 by krileon
Please search the forums with keyword "BLOBs" and set the date range to any date. There are several topics as well as possible workarounds regarding this issue.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

7 years 2 months ago #231363 by rosshennessy
Replied by rosshennessy on topic comprofiler-table reaches maximum database-fields
Hi,

Yes, I found a fix that Beat posted nearly 5 years ago.
He also said this would be fixed in a future version.
How many more years for this to be fixed.

www.joomlapolis.com/forum/64-rc3-general-discussions/78961-comprofiler-table-reaches-maximum-database-fields#78981

Please Log in to join the conversation.

7 years 2 months ago #231382 by krileon
It's going to be officially fixed in CB 2.0. Using text instead of varchar fixes the issue, but it slows down indexing and queries for the _comprofiler table. With CB 2.0 we'll be completely restructuring how fields are stored to avoid this from happening entirely.

I've created the below CB 1.9.1 bug ticket and will discuss internally if it'll be ok to officially make this change as we'll need to do a lot of profiling to ensure it doesn't negatively impact performance of too many users.

forge.joomlapolis.com/issues/4128


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

6 years 9 months ago #239454 by pask78
I have the same problem! How can I fix? Using version 1.9.
If I upgrade to the latest version 1.9.1 solves the problem?
Attachments:

Please Log in to join the conversation.

6 years 9 months ago #239492 by krileon
Please read the topic carefully. This is a known issue with a link posted to a quickfix. Upgrading to 1.9.1 will not fix this. It's fixed in CB 2.0. An alternative quickfix is to edit your database and change your database engine for CBs tables to InnoDB,


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.437 seconds

Facebook Twitter LinkedIn