Unsupported database CB Fields Group

4 months 2 days ago #306781 by matthewdavey
Im getting Unsupported database for Field Group searching and optimal storage. Please update to MySQL 5.7.8+ and ensure Community Builder is up to date.
My servers hostgator next MySQL is MariaDB and I dont think akeebabackup.com is compatible Im not sure what to do ?
Have I got to many cb fields?
Thanks
4 months 7 hours ago #306807 by krileon
MariaDB is not officially supported by Joomla and thus not by CB. We do not check MariaDB version. For searching to work and have optimal storage on MariaDB you'll need to be using MariaDB 10.2+. Otherwise be sure you be using MYSQL 5.7.8+ if you want searching capability and optimal storage (JSON instead of TEXT storage).


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
2 months 2 weeks ago #307480 by matthewdavey
I up graded my php MYSQL 5.7.8
I have configured it in 2 ways see attached
But im still getting a problem the green button Add Number
and Add Row
won't Add Number or Row in group fields.
Should I uninstall CB fields group plugin? Why would this be happening? must be a bug.
Thanks
Attachments:
2 months 2 weeks ago #307500 by krileon
If the buttons don't work to add new rows then you likely have a fatal JS error present on the page. Press F12 to open your browsers developer tools. Click the Console tab. Now refresh the page and see if there are any fatal errors present in the Console (they'll be red). You can test the repeat usage working fine on our demo site below as well.

demo.cbdemosites.com/


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
2 months 2 weeks ago #307543 by matthewdavey
Which browser to Press F12
My table structure looks like its missing something see attached should I uninstall it?
Thanks
Attachments:
2 months 2 weeks ago #307560 by krileon

Which browser to Press F12

Any of them. Chrome, FF, and Edge all open their developer tools with F12.

My table structure looks like its missing something see attached should I uninstall it?

It's not missing anything. There's nothing to put in those cells so only the minus button has a cell in that column.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
Moderators: beatnantkrileon
Time to create page: 0.392 seconds
Facebook Twitter Google LinkedIn