Error when making a field

1 month 1 week ago #316209 by matthewdavey
Im getting error when I try to make a field

Row size too large. The maximum row size for the used table type, not counting BLOBs, is 8126. This includes storage overhead, check the manual. You have to change some columns to TEXT or BLOBs

Then it makes the field but its broken somehow?

And some fields not showing up in tabs as they should?
I thinks CBuilder is out of memory to use on my website?
I don't know what is wrong?
Thanks
1 month 1 week ago #316214 by krileon
Looks like your database isn't configured properly. There is a limit to the number of columns a database table can have which puts a limit on the number of fields you can have. For a properly configured Innodb database that limit should be around 1000 fields. See the below topic regarding this issue and for solutions.

www.joomlapolis.com/forum/255-developer-members-support/239751-solved-problem-row-size-too-large


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
1 month 1 week ago #316224 by matthewdavey
Ok
So I guess out of all the posts I see

Have them configure the following.

innodb_large_prefix = 1
innodb_file_per_table = 1
innodb_file_format = Barracuda

This will ensure your database is ready for what you're wanting to do. The rest is up to you as long as it meets Joomlas minimum requirements. CB has been tested and works on PHP 7.1

Im using PHP is 7.2.26 MySQL is 5.0

I saw this in one of the posts

A new mysql instance has now been installed with the following innodb parameters:
- innodb_page_size = 64k
- innodb_log_buffer_size = 32M
- innodb_buffer_pool_size = 512M

After that I entered as much as an A4 lorum ipsum text in all six textarea fields, without experiencing any problems until now.
Of course we will continue testing because it concerns a lot of sensitive information. That MUST be good. Hopefully we will not encounter any more problems because Community Builder is a very nice solution, also for this type of application.??
?????

I guess this is it

phpmyadmin settings:
Storage Engine: InnoDB
ROW_FORMAT: DYNAMIC

database settings:
innodb_large_prefix = 1
innodb_file_per_table = 1
innodb_file_format = Barracuda

Eventually we'll be completely redoing how fields are stored. Ideally we'll use a separate table that is just joined together with _comprofiler and in theory would allow for unlimited fields, but that won't be until at least CB 3.0.

Ok so where do I go from here?
If the above is correct it should work?? and I shouldn't get the error?
Thanks
1 month 1 week ago #316236 by krileon
Yes, the above configuration should work fine and is how Innodb should be setup. You should make a full database backup before making any changes like that.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
1 month 1 week ago #316270 by matthewdavey
I contact my host and they replied

Thank you for updating this case with that information. My name is Michael G. and I am a Tier 3 Web Advisor. I understand you have contacted us regarding MySQL settings.

Some of the settings were already present:
innodb_file_per_table=1
innodb_buffer_pool_size=128M
innodb_log_buffer_size=64M

It may not be advisable to change the innodb_buffer_pool_size but if you insist that it is required, then we can try it for you.

One setting is not able to be changed without additional work, due to the way it changes how InnoDB functions on a whole for the server:
innodb_page_size = 64k

The following settings were added:
innodb_large_prefix = 1
innodb_file_format = Barracuda

Please don't hesitate to reach out to us again if you have any further concerns or questions. Live billing and technical support are available by phone and chat 24/7 to assist you with general issues and questions.

But I still get the error when I try to make a field
Row size too large. The maximum row size for the used table type, not counting BLOBs, is 8126. This includes storage overhead, check the manual. You have to change some columns to TEXT or BLOBs

Thanks
1 month 1 week ago #316287 by krileon
The only changes you should need to make are provided in my reply below.

www.joomlapolis.com/forum/255-developer-members-support/239751-solved-problem-row-size-too-large?start=6#307225

The other changes are suggestions by other users which may or may not help. The user in that topic is using unsupported MariaDB so their changes may be different than yours. If you are using MariaDB instead of MySQL then you are using an unsupported database type as well. Beyond that there's nothing more I can suggest. Your issue is entirely related to incorrectly configured database or unsupported database type, which we can't assist with. If you're unable to resolve your issue you'll need to contact your host and see if they can fix the configuration otherwise you've hit the field limit for your database.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
Moderators: beatnantkrileon
Time to create page: 0.425 seconds

Facebook Twitter LinkedIn