CB Privacy

1 week 55 minutes ago #318639 by phcprod
me too I'm not understanding why I have this problem with cb privacy since the begining of the cb installation when all the other plugins work very well.
The credentials are sent to your pm
6 days 2 hours ago #318663 by krileon
Seams to be working fine using the credentials you've provided. Both in the mini edit display immediately after upload and on media edit.




Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
Attachments:
6 days 1 hour ago #318667 by phcprod
Probably because your credentials are those of super admin, in this case the confidentiality rules are not applied.
I see the same thing with my login.
I send you by pm the credentials of an author and you will see the problem.
6 days 1 hour ago #318668 by krileon
That's working as expected. They're not allowed to select a view access level they've no access to. It filters the view access levels down to those that are visible to the user. It's strange it's still outputting the optgroup label though and have added a bug ticket for that.

forge.joomlapolis.com/issues/8020

Have also added a feature ticket to implement a parameter to allow ignoring that check.

forge.joomlapolis.com/issues/8021


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
6 days 34 minutes ago #318669 by krileon
Ok, bug has been fixed and new parameters to toggle on the visibility check have also been implemented. Both are available in the latest build released just now. Once installed within CB Privacy > Parameters > Rules turn off the view access level visibility parameter to have the behavior you're wanting.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
Moderators: beatnantkrileon
Time to create page: 0.403 seconds