[SOLVED] CB Activity - Paste Image Instead of Upload

4 months 3 weeks ago - 4 months 3 weeks ago #315089 by Deveshi
Hi,

This one might be a bit far out there but I was wondering if it would be possible to enable users to paste images into the activity wall as an alternative to uploading the image. This would be particularly relevant when using the windows snipping tool where the snippet can be copied to clipboard (obviously there are wider uses such as simply copying web images to clipboard). Essentially, I am looking to cut out the middle steps of having to save an image to the users computer to then upload it to the activity wall... Copy and paste is a lot more user friendly.

This feature is available on Discord so I'm just wondering about the feasibility of adding it to Community Builder?

Thanks
4 months 3 weeks ago #315092 by krileon
That already exists and works. Ensure CB Gallery is installed and published. Next ensure gallery uploads are enabled (this is default enabled) within CB Activity > Parameters > Activity > Gallery. Now when making a post click the media share button that displays the drag and drop upload area. Next just paste your image. It should upload fine. It's not possible to do this without CB Gallery as CB Activity has no image upload or image processing code and is offloaded to CB Gallery.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
4 months 3 weeks ago #315094 by krileon
Looks like there's a minor bug with this though. If pasting while viewing an activity stream it doesn't expand the message nor activate the media button, but still does the upload. This is now fixed in latest available CB Gallery build.

forge.joomlapolis.com/issues/7754

Now when looking at a stream and you attempt to paste an image it will expand the message display and activate the media button automatically so it no longer requires 2 manual clicks to reach that step. This is likely the behavior you were expecting.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
The following user(s) said Thank You: Deveshi
4 months 3 weeks ago #315096 by Deveshi
Yup, its now working perfectly. Thanks very much.

Just want to say that by a substantial margin you have provided the best support I've received for a Joomla product. Thanks for all of the hard work!
The following user(s) said Thank You: nant, krileon
Moderators: beatnantkrileon
Time to create page: 0.417 seconds

Facebook Twitter LinkedIn