CBSubs history log

4 years 10 months ago - 4 years 10 months ago #292212 by poml
CBSubs history log was created by poml
Hi,

today I encountered an error message when trying to display the CBSubs history log:
An error has occurred.

0 String could not be parsed as XML

I think the offending entry is something that came back from PayPal when a user from Korea did his payment. I checked in phpmyadm and I think the problem is

<field name="address_state" value="" />

which was returned. I think it might be from PayPal, because locally we don't ask for a "state". The affected table name would be

#__cbsubs_payments

Is it possible to do something about it? This might be corean characters returned by PayPal, but they break the CBSubs history log.

Thanks.

Please Log in to join the conversation.

4 years 10 months ago #292220 by krileon
Replied by krileon on topic CBSubs history log
Sounds like for some reason PayPal API returned invalid XML. Clear the history and see if it happens again after checking that your database tables have their collation correctly set to utf8.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

4 years 10 months ago #292232 by poml
Replied by poml on topic CBSubs history log
Yes, it has happened again: Now with a client from Russia, who had some (probably) cyrillic characters in the fields
<field name="first_name" value="" />
<field name="last_name" value="" />

Please Log in to join the conversation.

4 years 10 months ago #292244 by krileon
Replied by krileon on topic CBSubs history log
Are there any issues with the actual payments or is this strictly a problem in the history log? If it's strictly a problem in the history log it likely is just a storage problem. Check that _cbsubs_history and its columns are utf8 collation.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

4 years 10 months ago #292331 by poml
Replied by poml on topic CBSubs history log
The payments work fine.
It seems to be only a problem with the history log.
I checked in phpmyadmin and I see in the structure under Collation "utf8_general_ci".

Please Log in to join the conversation.

1 month 3 weeks ago #327301 by poml
Replied by poml on topic CBSubs history log
I am still having the same problem. Does the collation need to be different from "utf8_general_ci"?

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.173 seconds