[#7097] UserList Management - Email Link

8 months 2 weeks ago - 8 months 2 weeks ago #303365 by bizguy
How can I add a link to a user list, that will go directly to the email form?
In the Email field configuration:
  • I have turned on icon and text for Profile Display which displays and correctly links to the email form
  • I have turned on icon only for Userlist Display which displays correctly but when the link is followed, redirects to the default user profile page NOT the email form
The icon link correctly displays the url of the email form, but redirects to the profile page.

Thanks for your help
8 months 2 weeks ago #303369 by krileon
Looks like the binding to link to profile isn't ignoring it due to the click event happening on the span element for the icon instead of the a element for the link. Recommend changing userlist usage to text only and have added a bug ticket to improve the jQuery so it can handle those scenarios.

forge.joomlapolis.com/issues/7097


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
8 months 2 weeks ago #303378 by bizguy
Thanks Kyle.

I tried the icon and text option, but clicking on the text linked to the form, but hitting just the icon had the same effect of directing me to the user profile. I changed it to text as recommended, which works correctly.

Thanks for the work-around.
Moderators: beatnantkrileon
Time to create page: 0.379 seconds
Facebook Twitter Google LinkedIn