[SOLVED] After update to CB 2.3 CB conditional stopped working on registration page

3 weeks 5 days ago #308667 by krileon
It uses the hidden class to actually hide it. cbDisplayDisabled is to keep track of what was disabled. Are you conditioning the field with CBSubs and CB Conditional? You are not supposed to be conditioning it twice like that as they will conflict (this has always been the case and is not recent). CBSubs reversing its condition could explain why the hidden class is being removed.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
3 weeks 5 days ago #308668 by activha
No we did not change anything for a few months on these.
All was working as intended until recent updates from last week.

CBsubs related plan was set to hide the field also on registration if selected and that was the problem. Deselecting this field from the list of hidden ones by the plan for registration seems to solve it.

On the reverse, deactivating the condition on the field itself and reactivating the CBsubs plan hidden feature for the field does not seem to work as user has to select the field before choosing a plan, and selecting a plan by default brought other problems if I remember well.

Anyway, that's solved this way
The following user(s) said Thank You: krileon
Moderators: beatnantkrileon
Time to create page: 0.373 seconds
Facebook Twitter Google LinkedIn