[#7833] Members list layout change after upgrade to 2.4.3

2 months 1 week ago - 2 months 1 week ago #316431 by pastoweb
Hi, with the last update to version 2.4.3 of CB something seems changed in the members list layout:

here is my production site with previous version:
formalms.org/association/members-list.html

This is the test site with version 2.4.3:
formalms.org/PORTAL/index.php?option=com_comprofiler&view=userslist&searchmode=2&Itemid=314

I see a new div with the classes "col-sm-3 cbColumn3 cbUserListRowColumn cbUserListRowCol1" in the html that is breaking my layout, is there a way to control it in configuration?

<div class="pb-2 col-12 col-sm-6 col-md-3 pr-sm-1 pl-md-0 pr-md-1 cbUserListRow" role="row">
<div class="card no-overflow cbCanvasLayout cbCanvasLayoutSm">
<div class="card-body p-2 position-relative cbCanvasLayoutBody">
<div class="row no-gutters cbCanvasLayoutContent">

<div class="col-sm-3 cbColumn3 cbUserListRowColumn cbUserListRowCol1" role="gridcell">

<div class="cbUserListFieldLine cbUserListFL_cb_logo">
2 months 1 week ago #316437 by krileon
Column Size wasn't working for grid usage. It was a bug that was fixed in CB 2.4.3. Edit your userlist and adjust the Column Size for your other columns. It previously only worked for the first column and now all columns properly work with column size.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
2 months 1 week ago #316455 by pastoweb
Thanks, I checked my colums settings and they seem ok
I think the issue is with the screen detection, on my desktop screen it gets @media (min-width: 576px) instead of 768
Any idea?
2 months 1 week ago #316457 by krileon
Looks like you have only 1 column. The first column is used for grid sizing. Looks like it's being applied twice. Once on the outer display and a again on inner display and it shouldn't be doing that. Have added a bug ticket to fix. To workaround the issue have the first column have no fields and move your fields to a second column with a column size of 12.

forge.joomlapolis.com/issues/7833


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
2 months 1 week ago #316458 by pastoweb
Yeah, the workaround works perfectly, now I can update the production site, thanks!
Moderators: beatnantkrileon
Time to create page: 0.436 seconds

Facebook Twitter LinkedIn