CB Core Fields Ajax: "strange" code after saving

2 months 4 days ago - 2 months 4 days ago #316519 by zahmundzornig
Changes in front-end via the CB Core Fields Ajax ends with a strange code after saving. Please have a look on my screenshot:




"Geschlecht" shows a code instead of my choice "Mann". After reloading the page, "Mann" is displayed. The function works in the end, but it irritate our users. How can I avoid this code?

www.zahmundzornig.de thanx joomlapolis for the great work and support!
Build with CB: www.jaii.de
Attachments:
2 months 4 days ago #316522 by krileon
That's the ajax JSON response. Looks like something maybe altering the output and it can't parse the JSON. What type of field is that and what value are you supplying to it? Do all fields with ajax enabled do this or just that field? Based off your description something is chopping off the closing quote and bracket for the JSON response for some reason.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
2 months 3 days ago #316545 by zahmundzornig
This happens on all kind of field types. Date, Text, Image, Checkbox, ...
Yes, all codes missed the last part
"}

Any idea how I can proceed to find this conflict?

www.zahmundzornig.de thanx joomlapolis for the great work and support!
Build with CB: www.jaii.de
2 months 3 days ago #316549 by krileon
My guess is something is installed altering the data buffer and breaking the JSON response or something jQuery related is breaking the ajax response. Try switching to default Joomla protostar template and see if it's the Joomla template (templates can override endpoints). If issue persists see if you've any header compression extensions (e.g. jQuery and CSS compression extensions) and try disabling them. If issue persists ensure CBs jQuery is enabled in CB > Configuration > Integrations so CB won't use Joomlas or whatever other jQuery is available. If still not working best I can suggest is disable 3rd party System plugins within Extensions > Plugins to see if any could be conflicting.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
Moderators: beatnantkrileon
Time to create page: 0.471 seconds

Facebook Twitter LinkedIn