Cannot get captcha to appear on registration page on website

4 months 3 weeks ago #325579 by marriage_minded_man
Replied by marriage_minded_man on topic Cannot get captcha to appear on registration page on website
I'm using Google reCaptcha V3, and have entered the creds in the Joomla core plugin "CAPTCHA - Invisible reCAPTCHA", and updated the Joomla Global Config to use "CAPTCHA - Invisible reCAPTCHA".

Initially, I was changing the settings for the CB Antispam FIELD ("Parameters > Captcha > General > Mode") to use "Joomla" which was enabling "CAPTCHA - Invisible reCAPTCHA" on sign up form but NOT the Forgot Login form. I realized that I needed to leave that set to "Same as Global", and to instead make the change under "CB > Plugin Management > Antispam > Config" and set THAT to "Joomla". It now works for both the Registration form and the Forgot Login form. Is this the correct way?

Is there a way to enable "CAPTCHA - Invisible reCAPTCHA" for the entire site (all Guests who aren't logged in), since the Login Module will be on every page? Is there not a benefit to doing this?

Thanks.

Please Log in to join the conversation.

4 months 3 weeks ago #325580 by marriage_minded_man
Replied by marriage_minded_man on topic Cannot get captcha to appear on registration page on website
I think I found it: under "CB Antispam > Parameters > Captcha > Legacy". Wow, lots of settings. Love all the features here, especially the "Notify User".

Please Log in to join the conversation.

4 months 3 weeks ago #325583 by krileon

It now works for both the Registration form and the Forgot Login form. Is this the correct way?

Yup, that will change the captcha globally.

Is there a way to enable "CAPTCHA - Invisible reCAPTCHA" for the entire site (all Guests who aren't logged in), since the Login Module will be on every page? Is there not a benefit to doing this?

Personally I don't recommend enabling it for login form. Username and password alone are basically a captcha as is. I would suggest only enabling captcha for registration and forgot login forms.

I think I found it: under "CB Antispam > Parameters > Captcha > Legacy". Wow, lots of settings. Love all the features here, especially the "Notify User".

Yup, that's the correct location to enable login captcha.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.133 seconds

Facebook Twitter LinkedIn