User never getting access to subscription

9 years 7 months ago #218173 by joshatplum
User never getting access to subscription was created by joshatplum
Im having a major functional problem with cbsubs running on Joomla! 2.5

After returning from our payment gateway, the subscription never activates, all of the IPN info is correct and the payemt is showing properly in cbsubs however the subscription is never generated and when the user returns it just asks them to pay again.

I have confirmed my settings are all correct via your documentation and with ccbill. Please advise

Please Log in to join the conversation.

9 years 7 months ago #218257 by krileon
Replied by krileon on topic Re: User never getting access to subscription
Any errors in history log? Did you receive the IPN in notifications? If so, was it errored?


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

9 years 7 months ago #218264 by joshatplum
Replied by joshatplum on topic Re: User never getting access to subscription
I got the IPN however i do now see this error

ccbill: The OrderId is missing in the return URL: Probably due to missing "cbsubs_ccbill_basket" cookie: Please contact site administrator to check error log.

Please Log in to join the conversation.

9 years 7 months ago #218271 by krileon
Replied by krileon on topic Re: User never getting access to subscription
Please PM backend super administrator login credentials and will take a look.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

9 years 7 months ago #218286 by joshatplum
Replied by joshatplum on topic Re: User never getting access to subscription
done

Please Log in to join the conversation.

9 years 7 months ago #218344 by krileon
Replied by krileon on topic Re: User never getting access to subscription
I see only 1 IPN from CCBill and it looks successful. The basket also looks paid for that IPN. Where are you seeing the orderid error? On return to your site from CCBill?

Note you don't have any subscriptions. All your plans are Merchandise plans. They do not generate subscriptions. So this is working as intended and as configured.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.197 seconds

Facebook Twitter LinkedIn