CB Tabs Protect not working after upgrade

9 years 2 months ago #222360 by stuntlist
Hi,

I have a Joomla 1.5.25 site with CB 1.8.1 and CB Subs 2.0.2. I have just upgraded it to CB 1.9 and CB Subs 3.0.

I have some tabs set so they are only visible depending on the user's subscription level. This was working fine before the upgrade, but now the tabs with CB visibility settings are no longer being displayed. Here is an example of how the Photos tab is setup:



The logged in user with an Annual subscription should have a Photos tab under their Profile, but they no longer do since the upgrade. None of the tabs with CB Tab Protect settings are working.

When I go to CB Subs settings I am not getting any error about the CB Tab Protect plugin being an incorrect version.

Is there something different you have to do with CB Tab Protect in the new version to get it to work?

Thank you.
Attachments:

Please Log in to join the conversation.

9 years 2 months ago #222800 by krileon
Replied by krileon on topic CB Tabs Protect not working after upgrade
Strange, configuration looks ok to me. We're using it here at Joomlapolis as well and it's working fine. Please PM backend super administrator login credentials and will take a look.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

9 years 2 months ago #223302 by krileon
Replied by krileon on topic CB Tabs Protect not working after upgrade
Have reviewed your install and appears to be working ok for me. Created a test user, subscribed them to Wardrobe and the Wardrobe tab now displays (did not display when I had no subscription). Can you provide exact steps on how to duplicate your results so may further review?


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

9 years 2 months ago #223306 by stuntlist
Replied by stuntlist on topic CB Tabs Protect not working after upgrade
Hi Kyle,

Wardrobe is a special user and doesn't get to see the extra tabs.

Your user needs to be an Apprentic, Annual or Coordinator user. For an Annual or Coordinator user they should now also get a Photos, Videos & Resume tab. For an Apprentice user they should get Resume & References tab.

I have some test users setup, I will PM you the username & passwords for these users.

Thank you for looking.

Please Log in to join the conversation.

9 years 2 months ago #223311 by krileon
Replied by krileon on topic CB Tabs Protect not working after upgrade
Your Resume and Gallery tabs weren't displaying because they are Plugin tabs (tabs rendered by a CB Plugin) and the plugins for those tabs were not enabled. I've enabled them for you and appears to be displaying fine now. Please also confirm is displaying fine. The plugins responsible for your Resume, Photo, and Video tabs that were disabled are as follows.

CB REMOSITORY
Gallery-Tab
hwdVideoShare User Videos Tab


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.198 seconds

Facebook Twitter LinkedIn