[SOLVED] [#8265] QuickPay subscription not working!

3 months 5 days ago - 3 months 3 days ago #321578 by rbuelund
I have just made a subscription on my website via the QuickPay plugin. The subscription is correctly added in QuickPay, but the amount is not withdrawn ?? I have renewed my subscription a month in advance, but shouldn't the payment be withdrawn instantly anyway?

Please Log in to join the conversation.

3 months 5 days ago #321590 by krileon
Replied by krileon on topic QuickPay subscription not working!
Depends on how you paid, but paying by bank card for example typically takes 24 hours for the payment to clear and will in a Pending state at your bank until it does, but once authorized (usually instantly) should go through at QuickPay. I've no idea how long QuickPay might take to withdraw a payment though.

Since QuickPay is a hosted payment solution our implementation is not responsible for collecting payment; we simply tell QuickPay how much to collect and send you to QuickPay to pay. I suggest contacting QuickPay regarding your issue.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

3 months 5 days ago - 3 months 5 days ago #321593 by rbuelund
Replied by rbuelund on topic QuickPay subscription not working!
Sorry, I think you misunderstand. The payment has not at all been initiated at Quickpay! Only the subscription. I have talked to Quickpay and the problem is that the QuickPay plugin has set the subscription at QuickPay but not initiated a payment wich must happen afterwards. I have been in on the the initial development of the plugin, so I know the flow.

Please Log in to join the conversation.

3 months 5 days ago - 3 months 5 days ago #321594 by rbuelund
Replied by rbuelund on topic QuickPay subscription not working!
I thought just came to me.. maybe this is a problem with the way I have set up the plans on our website. The plan is with an initial price for the first year and then a different price for the following years. We started the system when the members already had paid manually, so therefore we went in and activated all their subscriptions in february. Now they musy use the payment system for the first time, so could there be a problem here, that something is not initiating the payment correctly when you choose subscription ?

Please Log in to join the conversation.

3 months 4 days ago #321600 by rbuelund
Replied by rbuelund on topic QuickPay subscription not working!
Single payments ARE working, recurring payments are not.

Please Log in to join the conversation.

3 months 4 days ago #321607 by krileon
Replied by krileon on topic QuickPay subscription not working!
Ah, I see yes I misunderstood your issue, sorry.

Recurring payments for QuickPay use the CBSubs internal scheduler because QuickPay does not trigger the recurring payment themselves. Be sure you're running the URL in CBSubs > Settings > Global under "Automated payments (this is only for use if required and supported in payment gateway and by payment service provider)" on a regular basis. Once a day should be sufficient. It is best to schedule a CRON wget or curl call against that URL.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.442 seconds

Facebook Twitter LinkedIn