[SOLVED] Mailer links not working

3 months 4 weeks ago - 3 months 3 weeks ago #328759 by Leobici
[SOLVED] Mailer links not working was created by Leobici
Hi,
after 1 year of subscription i receiving now some feedback about the mail i setup to invite our subscribers to renew their plan (It's quite annoing there is no way to test it).

I put a relative url inside the mail but that's not working (index.php?option=com_comprofiler&view=pluginclass&plugin=cbpaidsubscriptions&do=displayplans&plans=2-3-4-7-6-9aidsubscriptions&do=display_subscriptions). Then i tried to put an absolute link but it doesn't get saved ( www.lifeintravel.it/index.php?option=com_comprofiler&view=pluginclass&plugin=cbpaidsubscriptions&do=displayplans&plans=2-3-4-7-6-9aidsubscriptions&do=display_subscriptions ) and i guess the editor cancel the absolute part of t the url www.lifeintravel.it/

I tried to modify in the tinymce editor plugin the absolute/relative url field with no luck. Do you have any other suggestion?

Thanks

Please Log in to join the conversation.

3 months 4 weeks ago #328772 by krileon
Replied by krileon on topic Mailer links not working
Can't use relative URLs in emails. They need to be full live paths. TinyMCE seams to leave the URLs alone in my test. What editor are you using? Worst case you can use [cb:config param="live_site" /] substitution to prefix the domain.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

3 months 3 weeks ago - 3 months 3 weeks ago #328778 by Leobici
Replied by Leobici on topic Mailer links not working
thanks,
I solved it by creating on the JCE editor a new profile dedicated to CB and in the editor parameters tab I assigned none to url conversion.

I cannot test it but i hope this will be fine
The following user(s) said Thank You: krileon

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.131 seconds

Facebook Twitter LinkedIn