[SOLVED] [#8265] QuickPay subscription not working!

3 months 4 days ago - 3 months 4 days ago #321608 by rbuelund
Replied by rbuelund on topic QuickPay subscription not working!
So what you are saying here is that if I renew in advance (1 month here) with the pay and signup, then the payment is not processed until my subscription ends 31/12 ?
I allready have this cronjob running every 2 hours, and the payment is still not initiated at QuickPay, so that is why I ask.

Please Log in to join the conversation.

3 months 4 days ago #321610 by krileon
Replied by krileon on topic QuickPay subscription not working!
How are you renewing in advance for a recurring payment? Manual renewals should not be possible on recurring subscriptions.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

3 months 4 days ago - 3 months 4 days ago #321612 by rbuelund
Replied by rbuelund on topic QuickPay subscription not working!
Well, first all our members were signed up manully in backend (I just marked them as paid) in february, as they had allready payed the member fee in another way (The way we used to). So now every member can renew in advance for the year 2021 and choose to pay single or pay and subscripe to recurring. So there has not actually been any real payments in the system yet.
But I believe this would be the same case if every user had made a single payment the first year, and then now, the second year, they want to change to recurring payment.

Please Log in to join the conversation.

3 months 4 days ago #321620 by rbuelund
Replied by rbuelund on topic QuickPay subscription not working!
Did you understand the situation i described ?

Please Log in to join the conversation.

3 months 4 days ago #321625 by krileon
Replied by krileon on topic QuickPay subscription not working!
Ok, as I understand it they were originally manual renewals. They've then renewed themselves into a recurring subscription. In that case yes it should have billed immediately. This however sounds like a problem with QuickPay still. The initial payment is always done immediately and that amount is correctly being sent to QuickPay so am unsure why QuickPay has not billed them. We are using the below API.

learn.quickpay.net/tech-talk/payments/form/#quickpay-form

Please contact QuickPay and have them take a look. The only difference for recurring subscriptions and non-recurring from our end is we have set "type" to "subscription". The internal scheduler takes care of the recurring payments themselves, but initial payment should have happened immediately. The scheduler_state and scheduler_next_maturity database columns in _cbsubs_payment_baskets hold the state and date for this functionality.

I however do not recommend using gateways that cannot provide the full billing process and require the internal scheduler. I highly recommend everyone be making the move to Stripe.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

3 months 4 days ago #321626 by rbuelund
Replied by rbuelund on topic QuickPay subscription not working!
The flow at QuickPay is that you first create a subscription, and after that you initiate a payment on that subscription - that is not happening automatically.

You can see that here: learn.quickpay.net/tech-talk/guides/subscriptions/#introduction-to-subscriptions

This is a very critical problem as I have two sites with over 500 members which have to pay within the next month ! And the whole reason to use CBSubs for this was, that people could sign up for recurring payment.

It is to late to change to Stripe now - this has to work...

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.431 seconds

Facebook Twitter LinkedIn