Can't use Paid Subscriptions Import

6 months 3 weeks ago - 6 months 3 weeks ago #326880 by peterbatchelor
[#8763] Can't use Paid Subscriptions Import was created by peterbatchelor
I'm having a problem when I go to Community Management > Plugin Management > Paid Subscriptions > Import.

Regardless of whether the source I select is a file with a single line of comma-separated user-IDs, or all users from a given subscription plan, and then choose the plan to subscribe them to, set the subscription state and the subscription date, when I click Import I see the following error message.

1146 Table '<table name here>.NONE' doesn't exist


I've tried to do imports on several of my sites, all running Joomla! 3.10.3 and up to date installs of Community Builder and Paid Subscriptions, and all fail in the same way.


System Information for the site I'm working on at present:

php: Linux m45.siteground.biz 3.12.18-clouder0 #6 SMP PREEMPT Mon Apr 12 16:04:39 EEST 2021 x86_64
dbserver: mysql
dbversion: 5.7.32-35-log
dbcollation: utf8mb4_general_ci
dbconnectioncollation: utf8mb4_general_ci
phpversion: 7.4.25
server: Apache
sapi_name: cgi-fcgi
version: Joomla! 3.10.3 Stable [ Daraja ] 21-October-2021 06:44 GMT
platform: Joomla Platform 13.1.0 Stable [ Curiosity ] 24-Apr-2013 00:00 GMT
useragent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:93.0) Gecko/20100101 Firefox/93.0

I've used Community Builder > Tools > Check Community Builder Database and also checked Community Builder User Fields Database with strict column types. All is green.

Looking for solutions in the forum, the closest I could come up with was www.joomlapolis.com/forum/277-cb-paid-subscriptions-support/243978-solved-failure-with-main-cb-subs-plugin-installation#324967

I've looked at the database collation, but utf8mb4_ci is not an option on my server, so I've stayed with utf8mb4_general_ci.

The database table prefix is mmp_j25_
Would the second underscore in the prefix be causing a problem?

Any ideas?
Peter

Please Log in to join the conversation.

6 months 3 weeks ago #326885 by krileon
Replied by krileon on topic Can't use Paid Subscriptions Import
Was able to confirm it's not working. Have created a bug ticket to investigate further. Looks like a regression as it was working fine.

forge.joomlapolis.com/issues/8763


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

6 months 3 weeks ago #326892 by peterbatchelor
Replied by peterbatchelor on topic Can't use Paid Subscriptions Import
Hi Kyle,
I've found that on some sites the import will still work if I roll CB back to 2.4.7.
On the most difficult site I found that if I installed CB 2.4.5 and CB Subs 4.4.0, and then installed the most recent versions of both I was able to get the import working again.
No idea why this fixed the problem, but very relieved :-)
Peter

Please Log in to join the conversation.

6 months 3 weeks ago #326901 by krileon
Replied by krileon on topic Can't use Paid Subscriptions Import
This has been fixed in latest CBSubs build release. Do not downgrade CB. We do not support downgrades. All data migrations are forward only.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

6 months 3 weeks ago #326910 by peterbatchelor
Replied by peterbatchelor on topic Can't use Paid Subscriptions Import
Thanks Kyle.
Peter

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.250 seconds

Facebook Twitter LinkedIn