AuthorizeNet auto recurring payment

1 month 1 week ago - 4 weeks 1 day ago #329520 by fdinkler
Replied by fdinkler on topic AuthorizeNet auto recurring payment
Hi
It only shows Error 003 and Payment failed there as well : prntscr.com/Kuxg7pVQh
Could u able to share some patch as its urgent to allow payments

Please Log in to join the conversation.

1 month 1 week ago #329521 by krileon
Replied by krileon on topic AuthorizeNet auto recurring payment
I have nothing to fix because I don't know what the problem is yet. Your error is coming from Authorize.net themselves. They're rejecting the XML. Have you tried contacting Authorize.net?

We have not touched Authorize.net payment gateway. There's no reason for it to spontaneously stop working other than issues outside of our control, which typically means Authorize.net changed something on their end.

You're welcome to PM (see link in signature) backend login credentials and will take a look, but you really need to contact Authorize.net and have them check their logs to see why it was rejected.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

1 month 1 week ago #329550 by krileon
Replied by krileon on topic AuthorizeNet auto recurring payment
Have invested further and confirmed a bug with Guzzle >= 6. We recently updated to Guzzle 7. XML POST requests are not being sent correctly.

forge.joomlapolis.com/issues/8960

Was able to implement a fix. Once reviewed and merged a new CBSubs release will be available fixing this issue. Have confirmed using Authorize.net sandbox the fix is successful and recurring profiles are creating.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

1 month 1 week ago #329554 by krileon
Replied by krileon on topic AuthorizeNet auto recurring payment
Latest CBSubs build release should be available now with this fixed.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

4 weeks 1 day ago #329601 by fdinkler
Replied by fdinkler on topic AuthorizeNet auto recurring payment
Hi
Thanks for the Fix.
I did pay for the trial and it worked ok for the first time.
On the day of Auto-Renew, the amount is deducted from the Authorize net. But membership is not Renewed in CB and the plan showed expired.
After checking on the CB plan show expired and new payment information not show that deducted for ARB.
upon further checking the Silent URL from CB is exist on the AUthorize net website.
loading that URL in browser show message : ARB-Silent: ARB silent post Hash check failed
Kindly assist if any settings missing.


Thank you.

Please Log in to join the conversation.

4 weeks 1 day ago #329604 by krileon
Replied by krileon on topic AuthorizeNet auto recurring payment
Was there any notifications in CBSubs > Notifications at the time of renewal? Silent Post should be logged there if it was sent by Authorize.net and received by CBSubs. If there's no notifications there then be sure the URL is absolutely correct and contact Authorize.net to see if they sent the silent post to that URL successfully. Accessing the URL directly isn't going to work as it's meant to receive payment data so direct access by you is not going to confirm anything. If your server or site has any kind of firewalls be sure they allow authorize.net IP Addresses through (you'll need to get those from them).


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.489 seconds

Facebook Twitter LinkedIn