Avatar field - frontend and backend differences

3 months 3 weeks ago - 3 months 3 weeks ago #329694 by cez
Hi,

on my test environment and on your demo site (v.2022.06.14), the same file uploaded as avatar / portrait from the user front or user backend displays differently, so I indicate the difference.

the original file is h: 1000px, w: 500px (not sure, but croping works in the backend, but from the front, probably not?)

greetings!
Attachments:

Please Log in to join the conversation.

3 months 3 weeks ago #329696 by krileon
On frontend it should've displayed the user cropping box to select how to crop the image. If that fails to load for any reason it just uploads as normally and does server side resizing. Below is what you should be seeing.




Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
Attachments:

Please Log in to join the conversation.

3 months 3 weeks ago #329704 by cez

On frontend it should've displayed the user cropping box to select how to crop the image.


Tested again (Firefox and Edge). Yes, and cropping box has displayed in both places... but results are different.
See screenshots from your demo.cbdemosites.com site (used same file as above):

Attachments:

Please Log in to join the conversation.

3 months 3 weeks ago #329705 by krileon
Seams to be working perfectly fine for me. Try moving the cropping area then saving profile. Maybe the initial crop isn't happening for you and if that's the case narrows down what I need to investigate.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

3 months 3 weeks ago #329710 by cez
Well, I leave it, it's just a trifle and maybe only with me?
But...OK last try, I changed the file dimensions a bit to two versions: even and odd px and .png and .jpg and moved the crop window.
This time tested in Chrome.

On your demo site:

Suzan K. uploaded from the backend
User Demo uploaded from front end.


Same result: Already when approving the images you could see that there was / will be a difference.




And one more strange thing I just notice: Suzan (from backend) has info on stream that she changed Avatar a few minutes ago.

Demo User (uploaded from frontend) - although I changed the avatar several times after Suzan - still has info that the profile was updated an hour ago???

Attachments:

Please Log in to join the conversation.

3 months 3 weeks ago #329711 by krileon
Some of those updates were me as I was looking into it. You don't need to change the dimensions of the image itself. Just drag the cropping window up or down below the upload then save profile and see if that works fine for you. Aside from that I've no idea as again this is working fine in my tests so I don't have anything to go off of to see what could be causing this for you.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.224 seconds

Facebook Twitter LinkedIn