[SOLVED] wrong icon address in some plugins

13 years 1 month ago - 13 years 1 month ago #154690 by jojo12
Hi,
when I use cb_facebookconnect, cb_twitter and cb_connect, I have no images in loginpage.
with firebug I saw, that they are addressed in the CSS files with additional spaces
( images/... ) instead of (images/..)
When I change that, I can see the icons.

for example in facebookconnect.css line 3, 9, 13 etc.

I looked this in j1.5 until now I didn't try this in j16
(is this a new rule in j16 to add a space before and after the url?)

Please Log in to join the conversation.

13 years 1 month ago - 13 years 1 month ago #154877 by krileon
Replied by krileon on topic Re: wrong icon address in some plugins
Space makes no difference in CSS. It should not matter. I could not confirm your issue on Joomla 1.5 or 1.6. Please advise what browser you're using? Please note you should NOT be using FBC, Twitter, AND Connect at the same time. CB Connect has Facebook and Twitter built in. Please see the below W3 CSS specifications.

The format of a URI value is 'url(' followed by optional white space followed by an optional single quote (') or double quote (") character followed by the URI itself, followed by an optional single quote (') or double quote (") character followed by optional white space followed by ')'. The two quote characters must be the same.


Spaces are perfectly acceptable and valid markup. It can be formatted in about 5 different ways.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

13 years 1 month ago #154914 by jojo12
Replied by jojo12 on topic Re: wrong icon address in some plugins
I am using ja_t3_blank template. Perhaps it's together with that t3_framework, but I don't know.

Please Log in to join the conversation.

13 years 1 month ago #154917 by krileon
Replied by krileon on topic Re: wrong icon address in some plugins
No idea, the mark up is perfectly acceptable and valid. If removing the spaces works for you then is probably the best approach. Do not know what the framework you've mentioned is, sorry.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

13 years 1 month ago #154967 by jojo12
Replied by jojo12 on topic Re: wrong icon address in some plugins

krileon wrote: Please note you should NOT be using FBC, Twitter, AND Connect at the same time. CB Connect has Facebook and Twitter built in.


I don't see that CB Connect has Twitter too build in. And when I disable CB Twitter, then there's nothing.
With Facebook it is like that. You can disable facebookconnect. But with twitter it seems not to be true (for me).

Please Log in to join the conversation.

13 years 1 month ago #155008 by krileon
Replied by krileon on topic Re: wrong icon address in some plugins
You need to configure CB Connect, please see its configuration. Do not use CB Connect with FBC and Twitter. I can't stress this enough as you're loading duplicate libraries. Use either/or and never both. CB Connect supports Facebook and Twitter.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.286 seconds

Facebook Twitter LinkedIn