0 Unknown fetch type '8' for View My Profile menu item in Gantry Helium

2 months 4 weeks ago - 2 months 4 weeks ago #331374 by bascherz
This error happens in Joomla 4.2.4 when trying to view my own profile either via the menu selection or from the CB Login Module.

0 Unknown fetch type '8'

I just migrated this site from 3.10 to 4.2.4 and even reinstalled CB afterwards. I am not sure if this is an issue with CB, Joomla, or the Gantry Helium template, but it did not happen on another site I migrated earlier this week that uses the Hydrogen template. So I switched this site's template to Hydrogen. Same issue. Then to Cassiopeia. Ditto. I even tried just appending the following to the site URL and it did the same thing.
/index.php?option=com_comprofiler&view=userprofile

Not sure what to try next. Thanks in advance for suggestions.

CB version 2.7.4+build.2022.10.21.15.41.28.56bdcdeab

______________________
Bruce S - Vienna, VA

Please Log in to join the conversation.

2 months 4 weeks ago #331375 by bascherz
Very weird. This has magically repaired itself. But now I am having a similar issue with Phoca Downloads. It cannot get to the categories via the links it created itself. Is this some new J4 issue or something? It seems to be playing whack-a-mole with me.

______________________
Bruce S - Vienna, VA

Please Log in to join the conversation.

2 months 3 weeks ago #331385 by krileon
The below open issue is the only thing I could find regarding it.

github.com/joomla/joomla-cms/issues/35452

Within Joomla global settings under Server what is "Database Type" set to?

Issue seams like a problem in Joomla though and nothing we can directly do anything about. We're barely using Joomla APIs as is so it's unlikely core CB or any of our products would throw this and more likely it's a 3rd party extension or 3rd party CB plugin installed throwing it. I suggest going through your entire install and being sure everything is up to date.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

2 months 3 weeks ago #331391 by bascherz
I always use database type "MySQLi". The server is running MariaDB. Very strange behavior and even stranger that it just disappeared.

______________________
Bruce S - Vienna, VA

Please Log in to join the conversation.

2 months 3 weeks ago #331394 by krileon
It's possible it was just a caching issue which would explain it clearing up suddenly.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.219 seconds

Facebook Twitter LinkedIn