Troubleshooting Activity Implementation: Uploaded photos just show filenames

1 month 1 day ago #337829 by Pomond
Hi!
I'm implementing CB Activity for a use case that has a specific user group being able to add new Activity items to a stream at mckinleypark.news/sponsors-showcase/sponsor-news.

They were able to post a new Sponsor News item, but their uploaded images show up as file names and don't display the images themselves. (See either the URL above or screenshot.)

When I was testing this feature using another account, I had an issue with uploads to Activity until I enabled the CB Gallery plugin for these members.

This has got to be a permission thing, right? Or I am trying to reset the "page count" item so it's unlimited, then trying again.

I thought I'd ping you folks here to see if there's a likely culprit. I know it's a configuration option I'm overlooking ...

Any ideas? Thanks!
Attachments:

Please Log in to join the conversation.

1 month 1 day ago #337830 by Pomond
P.S.: The uploaded images do show up in the system! So they're being uploaded to CB, but not displayed. See attached screen shot of the CB Gallery - Media item.

 
Attachments:

Please Log in to join the conversation.

1 month 1 day ago #337836 by krileon
Ensure CB Gallery itself within CB > Plugin Management is public and publish. The image failing to load usually means the CB Gallery image endpoint is being blocked by something. You should see the network error in your browsers developer tools by pressing F12 and clicking the Network tab.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

1 month 3 hours ago #337852 by Pomond
Thank you for your prompt and helpful support (as always). I have ensured the Gallery plugin is published, which seems to have resolved the issue. Cheers!
The following user(s) said Thank You: krileon

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.166 seconds

Facebook Twitter LinkedIn