[SOLVED] CB Connect / Google Sign In / Throws "already in use" error on linked account

6 days 8 hours ago #308512 by benvoth
Thank you for your help! I was able to resolve the issue.

I was logged into two Google accounts at once in the same browser. When I used the "Link to Google" button, it didn't prompt me to choose which Google account to link with, it just immediately chose one of the two for me and didn't notify me which Google account it chose.

But then when I logged out and use the "Sign In With Google" button, it does prompt you to choose which Google account to login with and I was choosing the other Google account, the one that it didn't choose to link with.

Thanks again.
5 days 13 hours ago #308515 by krileon
Have reviewed your install and was able to find the issue. There was a bug in CB Connect type casting to integer the profile id during linking, which it should not have been doing. Type casting is fixed to the correct string casting. Have installed the fixed build (which is also now released) on your site and confirmed linking and login following linking works fine. Note you'll need to clear all the links/registrations you've done in your tests to see it working fine.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
The following user(s) said Thank You: nant
5 days 12 hours ago #308521 by benvoth
Thank you so much! It is working great.
The following user(s) said Thank You: krileon
Moderators: beatnantkrileon
Time to create page: 0.371 seconds
Facebook Twitter Google LinkedIn